PDA

View Full Version : The PHP extension mysql must be enabled to access this database.



cmiles
07-19-2011, 11:37 AM
Hey all, first of all this software is awesome and I we've used it before. We now have migrated our development/production equipment to other hardware and had to re-install Scriptcase.

I can log in, make a project and everything just fine, but when it comes to making a new connection I get an error even though MYSQL-PHP is installed/enabled:


Connection Error

The PHP extension mysql must be enabled to access this database.

This is a Linux Debian Lenny build with with MYSQL built into the PHP5 install, yet we get this error. Anyone have any ideas?

maxveras
07-19-2011, 04:12 PM
Hello,

Did you check in your diagnosis file, generated by Scriptcase ?
check if the mysql extension is enable, if its not, you can enable it in php.ini

regards

cmiles
07-19-2011, 04:20 PM
Hello,

Did you check in your diagnosis file, generated by Scriptcase ?
check if the mysql extension is enable, if its not, you can enable it in php.ini

regards


Yes,

/etc/php5/apache2/php.ini :


;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
;
; If you wish to have an extension loaded automatically, use the following
; syntax:
;
; extension=modulename.extension
;
; For example, on Windows:
;
; extension=msql.dll
;
; ... or under UNIX:
;
extension=mysql.so
extension=mcrypt.so
;
; Note that it should be the name of the module only; no directory information
; needs to go here. Specify the location of the extension with the
; extension_dir directive above.


Here is what our diagnostics look like:

http://pastehtml.com/view/b0zvypduq.html

maxveras
07-19-2011, 04:57 PM
Regarding your diagnosis your MySQL isnt enable, I noticed that you installed with Zend Server, right ?

You can enable via Zend Server, in the web browser, type the address : http://localhost:port/ZendServer
You must to configure in that interface.

cmiles
07-19-2011, 09:22 PM
Regarding your diagnosis your MySQL isnt enable, I noticed that you installed with Zend Server, right ?

You can enable via Zend Server, in the web browser, type the address : http://localhost:port/ZendServer
You must to configure in that interface.


To make a long story short, we ended up doing a clean install and were also informed that Zend won't work with the most recent version of PHP 5.3, you have to downgrade to PHP 5.2 and we were able to configure Zend correctly.

Also, Zend diagnosis is checking for version 4.1, we have version 5.1 (as a result of Scriptcase install) but the environment was functioning correctly. May want to make note of this whoever gets this information and passes it on to engineering.

We're up and working for the most part, the only diagnosis issue we have right now is environment permissions which is how we actually ended up doing a clean install to begin with. Accidently chmoded root of the Debian box and basically locked everything out, and since it's a new box it hasn't been configured for regular box.

Any known common problems on the permissions? The permissions on the opt folder should be set so they can be manipulated.

Thanks

smiles
07-20-2011, 01:14 PM
Session Write permission is the only check failing other than Zend 4.1.

We have tried both recursive chown and chmod with no success.

maxveras
07-20-2011, 02:21 PM
The reason why Zend v4.1 isnt ok in diagnosis file is because in Zend Server CE you dont use the zend optimizer, instead of Zend Optimizer, you need to enable in Zend Server configuration the Zend Loader, to load the encrypted files. This is been told in webhelp.

regards