Announcement

Collapse
No announcement yet.

MSSQL Connection Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MSSQL Connection Issue

    Have an issue connecting to MSSQL Server WCLUS which is using only Windows Auth.

    Any one can refer me to some guide to ensuring the proper config is in place for MSSQL server as I cannot connect from ScriptCase but can connect without any problem by using Database Browser app, from local machine.

    Is it maybe related to the actual 'user' that is used by scriptcase?

    Any help would be appreciated.

  • #2
    Or it is because you need to install the SQL Server native client on the server.. See http://msdn.microsoft.com/en-us/sqlserver/ff658532.aspx

    Comment


    • #3
      Actually RR the native client is already installed as per documentation. Does the installed native client affect if I have local installation of SQL Server Express 2012 and am attempting to connect to SQL Server 2005 remotely? Does anyone know of any compatibility issues here?

      Comment


      • #4
        if that is so then I guess you need to check your path under which you run your webserver, the sql server has to be reachable via its dll's so they have the be on the path somewhere.

        Comment


        • #5
          Could you clarify please? Did not quite understand your recommendation?

          Originally posted by rr View Post
          if that is so then I guess you need to check your path under which you run your webserver, the sql server has to be reachable via its dll's so they have the be on the path somewhere.

          Comment


          • #6
            Backgrounder now: Dev workstation Win7x64 with SQL 2005 Native Client installed.

            Cannot get to connect to MSSQL Server 2005. Tried all options, but connection info keeps complaining 'The user is not associated with a trusted SQL Server connection.' since only Windows Auth is setup on MSSQL Server 2005. Funnily enough though I can access this server through PHP code from a LINUX VM I have installed.

            Tried as a workaround to use ODBC using the odbcad32.exe to setup ODBC connection but when choosing to connect thru SQL Server ODBC seems there is some parameters mismatch wit the error '[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified odbc_exec() expects parameter 1 to be resource, boolean given'

            Any help here would be greatly appreciated

            Comment


            • #7
              The (actual) native driver is not fully compatibel with sql server 2005. Because sql server 2005 is already older, I recommend at least an update on sql server 2008 r2.
              Best regards: - Reinhard -

              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

              Comment


              • #8
                What I installed is the Native Client driver x64 for SQL Server 2005 (same version as SQL server). Will not be updating server at least for next 6 months where we will be migrating to newer more capable hardware.

                Or do you recommend Native Client driver x64 for SQL Server 2008 which would be able to connect to SQL Server 2005?

                Comment


                • #9
                  Oh that is interesting. I had not thought about that. Are you running 32 or 64 bits php? I dont know which server you use, over here I use uniform (32 bits) together with the 32 bits php client...
                  Anyway I use the Microsoft SQL Server 2008 R2 Native Client.L569 client. But i dont use mssql for my scriptcase, its all oracle here...
                  On the other hand I need mssql connections to a remote server this works fine with the mentioned client, which by the way also worked with the 2005 client.
                  I assume that the port number for your sql server express differs from the port number from the normal sql server..
                  There are too many things to check with mssql.. bah... 32/64 bits, native client 32/64 bits, port numbers, paths.
                  I'd try the Native Client driver x64 if your webserver is running on 64 bit, and the 32 bits driver if it is running on 32 bits.. I guess that thus depends on your webserver and php (32 or 64 bits).
                  Mixing 32/64 isnt always working...

                  Comment


                  • #10
                    You are very right RR, this is proving to be quite a pain.

                    How can I check whether PHP is 32/64?
                    The problem is inside Scriptcase so as such I am just using ScriptCase out of the box as web server not uniform as indicated.

                    Any recommended way forth? Should I create some VM I just use for the sake of development? 32bit possibly?

                    Comment


                    • #11
                      well if you can reach the server just rightclick your php exe and get the information you need. Otherwise a phpinfo.php should tell you as well.

                      Comment

                      Working...
                      X