Announcement

Collapse
No announcement yet.

Cannot setup Database Connect - Database Name field empty SC7.1.021

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot setup Database Connect - Database Name field empty SC7.1.021

    Hi,

    had to reinstall my local wamp server.

    In SC i updated the connection to reflect the new DB user.

    My SC development connection are working normal and i can use the db with newly created application from within the development area.

    When i used the URL http://localhost/mybowling2/framewor...i_manager2.php to update the connection on the local deployed webserver, i could not select any db.

    I use the same user/pwd as in the SC connection settings.

    What could be wrong here?

  • #2
    happened with me, i couldn't reach production environment when re-deployed my project the to the same place...

    are you able to open the production environment or having a white page?

    Comment


    • #3
      Have a login screen as first page on the application.
      I can no longer loging.

      have created a dummy login page an it came back with the fact i have no DB name selected.

      Any idea?

      Comment


      • #4
        did you go to production and set your connection there? you have to do this in the production before logging to any application in your project
        if you mean you have the production environment login, then log in usine password "scriptcase" or if you changed earlier, use that one..

        i had an issue earlier that i can't login to production environment at all when re-deploying, white page was only... then i used direct link to index.php as stated by Giu in one of the threads here in the forum and it works

        can you post a screenshot of your said-so screen?

        did you try to remove the whole folder from the localhost and re-dploy it with common libraries (fresh deployment)

        Comment


        • #5
          No, i did like it should be working and opened the url, mentioned before, and edit the connection.

          When editing the connection it tested ok but it didn't show any db's.

          I use the same user and pwd in SC for the connection and when i compile and run an application it works.
          Last edited by rodiusd; 06-15-2014, 01:07 PM.

          Comment


          • #6
            I would recommend fresh deployment, alternatively, if you can, access the production environment setup again to add the connection again
            forget about accessing the manager2.php and edit from there

            or i don't understand your question

            Comment


            • #7
              Ok, can you tell me how i can access the production environment.

              I believe its done by the manager2.php script.

              Or is there another way?

              Comment


              • #8
                I don't have it clear.

                First, did you login to production environment on localhost/yourapp/_lib/prod
                Default password is scriptcase

                I don't understand if you can't login to your app, or against the production environment
                /Giuseppe

                Professional Scriptcase Services
                Some Customers opinions

                Comment


                • #9
                  Hi,

                  this is given me the same as the URL i mentioned in the starting thread.

                  I include a screenshot. You can see that the connection test is ok but no db's are listed.

                  When is using the same credentials from CS its showing the different db's.

                  Any Idea?
                  Attached Files
                  Last edited by rodiusd; 06-15-2014, 04:15 PM.

                  Comment


                  • #10
                    Sorry, can't open atrachment
                    /Giuseppe

                    Professional Scriptcase Services
                    Some Customers opinions

                    Comment


                    • #11
                      I had this same problem when using xampp. You may have received an error message about MySQL being deprecated, and the Database list will appear blank.

                      I moved the xampp server to a new machine, however when i did so i downloaded the latest version of Xampp. It's my understanding that MySQL extension is deprecated as of PHP 5.5.0, and will be removed from future versions of XAMPP and WAMPP. Instead, the MySQLi or PDO_MySQL extension should be used. If you have re-installed Wampp and are using MySQL, then it may be that you have installed the latest version of WAMPP with PHP 5.5+.

                      My quick fix for this was to just revert to a version of XAMPP before it incorporated PHP 5.5+.
                      2 options are that you need to upgrade your MySQL database to MySQLi, or downgrade WAMPP to a version that has no higher than PHP 5.4.

                      Hope that helps.
                      Last edited by mikelaw; 06-17-2014, 06:49 AM.

                      Comment

                      Working...
                      X