Announcement

Collapse
No announcement yet.

Problems with html editor, loosing the absolute path

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with html editor, loosing the absolute path

    Hello,

    I have a from application dealing with an HTML editor.
    The problem is that everytime I put an absolute path like http://XXXX.com/rrr.jpg it converts it in a relative path like ../rrr.jph
    Iknow the solution which is changing the parameter that cals the editor: 'relative_urls:false' but I don't know how to do it in SC

    Any comments?

    Many thanks

    Artur

  • #2
    Re: Problems with html editor, loosing the absolute path

    Hello Artur,

    Please contact our support as an installation problem regarding this issue.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Re: Problems with html editor, loosing the absolute path

      Bernhard,
      I logged this with a ticket some time ago. Never did get a response. I then started a thread elsewhere here about the problem as well.

      The path gets changed on code generation.

      Cheers
      The GuiGuy
      ... from Down Under

      Comment


      • #4
        Re: Problems with html editor, loosing the absolute path

        Hello GuiGuy,

        The problem is that the problem description was a little too vague. I cannot tell how you are referencing the absolute path. Is it a img tag? Is it a simple link? As I asked earlier, please contact our support regarding this issue.

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          Re: Problems with html editor, loosing the absolute path

          Thank you,

          I've contacted but with no reply will do it again,

          There is an <img> inside the html editor I put the absolute path to that image (which is located in another web site), when I click onn save, and open it again it have chagen to relative path,

          I hope its more clear now,

          Best regards

          Artur

          Comment


          • #6
            Re: Problems with html editor, loosing the absolute path

            Hello,

            I've contacted the support and the ask me to make a copy of the site and reinstall again

            Comment


            • #7
              Hello,
              I have the same issue in my production website but not in my qualification one. The qualification website is deployed in a subdirectory under the root directory of my production environment. If the url corresponding to the prod website is for example: http://prod.website.com all the urls in the html editor which begin with http://prod.website.com are concerned by this issue and replaced by something like ../../.
              Now if the qualification website url is for example: http://qual.prod.website.com, all the urls in the html editor which begin with http://prod.website.com are not modified when the content is saved. I hope this will help to solve this bug.

              Comment


              • #8
                Hi

                The problem is still present in 7.01.0009

                We use HTML Editor to create e-mail to send. The application ( production ) is on the same domain where the images are linked.

                i.e. application on www.domain.com/app and images on www.domain.com/images

                Everytime i insert an image with link http://www.domain.com/images/myimage.png this is replaced by ../../images/myimage.png
                Inside the app images are displayed but when i send a mail the reference cannot be resolved.
                Giorgio Bravi
                Dolphin Software & Thinkware
                www.dolphin.it

                Comment


                • #9
                  And this problem will persist in any new version of SC as this is a problem in tinyMCE. Don't know why tiny does this, but it has been for years. If you need to solve this then you need to perform a stringreplace on the onbeforeupdate/insert to change ../../ by your url.
                  Albert Drent
                  aducom software netherlands
                  scriptcase partner, reseller, support and (turn-key) development
                  www.scriptcase.eu / www.scriptcase.nl

                  Comment


                  • #10
                    Hello,

                    Issue reported to our bugs team.

                    regards,
                    Bernhard Bernsmann

                    Comment


                    • #11
                      Originally posted by bartho View Post
                      Hello,

                      Issue reported to our bugs team.

                      regards,
                      Bernhard Bernsmann
                      I think the group of development and that of the support do not speak at all between them.
                      I'm trying to explain the problem in a ticket that I opened several days ago but it seems that no one is able to remotely understand what we're talking about.
                      Please look at how to solve the problem. is explained in this link.

                      http://www.tinymce.com/forum/viewtopic.php?id=642

                      Google is so simple to use ... and also the Translator....

                      e só para ter certeza alguém entende

                      Penso que o grupo de desenvolvimento e de que o apoio não falar em tudo entre elas.
                      Estou tentando explicar o problema em um bilhete que abri há vários dias, mas parece que ninguém é capaz de compreender remotamente o que estamos falando.
                      Por favor, olhe para a forma de resolver o problema. é explicado neste link.

                      http://www.tinymce.com/forum/viewtopic.php?id=642

                      Google é tão simples de usar ... e também em que o tradutor
                      Giorgio Bravi
                      Dolphin Software & Thinkware
                      www.dolphin.it

                      Comment


                      • #12
                        Don't know why I missed that one. *G* I'm looking for years for this option. It's been anoying me in E107CMS for years and so simple to solve. Tnx!
                        Albert Drent
                        aducom software netherlands
                        scriptcase partner, reseller, support and (turn-key) development
                        www.scriptcase.eu / www.scriptcase.nl

                        Comment


                        • #13
                          You're welcome!

                          You helped me with your suggestions in many other cases
                          Giorgio Bravi
                          Dolphin Software & Thinkware
                          www.dolphin.it

                          Comment


                          • #14
                            That's what the forum is for :-)
                            Albert Drent
                            aducom software netherlands
                            scriptcase partner, reseller, support and (turn-key) development
                            www.scriptcase.eu / www.scriptcase.nl

                            Comment


                            • #15
                              Found a workaround

                              in /prod/third/tiny_mce/tiny_mce_src.js

                              replace the origina setting:

                              convert_urls:1;
                              relative_urls:1;

                              with

                              convert_urls:0;
                              relative_urls:0;


                              and don't forget to clear the cache!!!

                              this for development and production too but don't forget to do the same every time you upgrade SC... an option in tinyMCE toolbar or a better editor should be nice..
                              Giorgio Bravi
                              Dolphin Software & Thinkware
                              www.dolphin.it

                              Comment

                              Working...
                              X