Announcement

Collapse
No announcement yet.

New record in an editable grid view

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New record in an editable grid view

    Hi

    I have a editable grid view with the option "Use modal form to edit" turned on. When I click on the pencil to update a record it shows me modal screen where I can adjust the data. Just what I expected and want. But when I add a record it shows me a new line in the grid where I can put in my data like an editable grid. And that is not correct I think, it should show me also a modal screen.
    When you only have a few fields it is not a big problem, but if you have 20 fields then editing a record in tte grid itself is not nice.

    See also my previous Thread about columns in the grid and in modal screen. I do not want all 20 fields in the grid but I want all 20 fields on the modal screen.

    Any ideas or suggestions.

    Thanks
    Andre

  • #2
    It's a work-around, but you can set autoinsert off. That way you still will see the grid, but not in insert mode. Clicking insert will show the modal form. Other way is to create a traditonal grid with an application link to a form. This will work similar to what you want afaik.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Thank Albert for your quick reply.

      Where can is find this autoinsert. I am unable to find it.

      I have tried it also with a traditional grid, but then my self-made buttons do not show up on the grid.

      Please notice that this editable grid is a detail screen as a part of master/detail form.

      I really like the modal view, as I still can see the underlaying main form when I edit my details.

      Brdgs
      Andre

      Comment


      • #4
        If I have a traditional grid. And I run it, see all kinds of buttons, like Add and also the QuickSearch.
        But when I make this grid as a detail form on a master/detail form then all buttons and the QuickSearch and the pencil disappear.
        Why is that. Why is SC not consistent in how it works.

        Thanks
        Andre
        Last edited by andre; 03-22-2013, 10:33 AM.

        Comment


        • #5
          Hi
          I have now an editable grid view in a master/detail form.
          The Add button is visible and works. It is linked to a separate form. But when I click on the pencil I get a modal view (model view is turned on) with not all fields of the table. But under links I have made a link for the correct form. But he is still using his own form.
          When I turn off the modal view, and I click on the pencil it edits the records within the grid. And when I click on the Update Record button to save the changes it shows my form with the updated data. Really stranges.
          SC is not consistent on this point or this is a major bug.

          Thanks for your thoughts.

          Andre

          Comment


          • #6
            Hello Andre,

            I'm pretty sure you have to configure those fields that aren't being shown to appear. Please contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

            regards,
            Bernhard Bernsmann

            Comment


            • #7
              Hi Bernhard,

              See my other thread we had contact about. It is the same problem.

              Brdgs
              Andre

              Comment


              • #8
                Will do that Andre. At first I thought it was the same issue, but then I had different interpretations for both.

                regards,
                Bernhard Bernsmann

                Comment

                Working...
                X