Announcement

Collapse
No announcement yet.

[SOLVED] missing seperators in date field

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] missing seperators in date field

    it is making me nuts ...

    got a bigger form containing four date-fields. In the beginning it was everything OK, after some time the seperators in the date fields are gone.

    1. Does not matter whether it is set on "Regional Settings" or not.
    2. Changing "Display" e.g. from DDMMYYYY to MMYYYY works, but without seperators too ...
    3. Chaning the data-type to Sting, shows the correct DB-Data containing seperators, changing back to date format, unfortunally the seperators are still gone
    4. including a "New Field" with the type date is working as intended, including seperators

    Is there someone who had the same problem or can give me a hint what I made wrong?
    To copy the date-fields to "New Field"s after calling the DB-record and copy back before update/insert would work, but really that sounds crazy ... no real solution for me.

    BR

    Eric

  • #2
    Sc Version?

    Comment


    • #3
      Sry, had missed that point in my post: Version 7.00.0018

      I tried some more settings of the "Form Settings"->"Fields"->"Fieldname"-> "Value Format"
      - If the option "use combobox" is set to yes, the seperators are shown, unfortunally the unwanted comboboxes are shown. I can see the seperators without the comboboxes, if I set the field to readonly by code.
      - the solution makes no sense, if I want to have a normal changeable field without combos.
      - I also got date fields like inserted on and changed on. First I made date fields out of them with the option label field yes. the solution above does not work. So I hat them to make a normal date field and switch them to readonly by code, not the best way ...

      BR

      Eric

      Comment


      • #4
        OK, found my mistake. For everyone, having the same problem?

        "Form Settings" -> "Toolbar" -> "Options" -> "JS Formatting" was set to No, but has to set to yes ...

        After setting this correct to yes, everything was fine again.

        Comment

        Working...
        X