No announcement yet.

Lookup with different connection

  • Filter
  • Time
  • Show
Clear All
new posts

  • Lookup with different connection

    I do not know if the problem is related to new versions or not but at least from 7.01.10

    Tested today with SC 7.01.0012

    I have a project with 2 different connections to different databases (let us call CONN_DB1 and CONN_DB2).
    I created a Form to manage the table TBL01 on the connection CONN_DB1. Everything OK.

    One of the fields has to be decoded & validated on the table TBL02 present on the connection CONN_DB2, so I created a lookup defining connection = CONN_DB2. Everything works fine creating the statement with the wizard.

    Problems starts during the generation process that displays an error saying that the table TBL02 does not exist on the database on the connection CONN_DB1. This is obvious!! The table TBL02 is present "only" on the database connection CONN_DB2 and not on CONN_DB1.

    Already opened a ticket 2 weeks ago but as usual no solution and no forecast.

    Has anyone had this kind of problem?

    Thanks for your attention.
    Giorgio Bravi
    Dolphin Software & Thinkware

  • #2
    Try sc_reset_change_connection() after your lookup.
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)


    • #3
      Unfortunately i can't because i'm using the lookup section on the field properties... and the message is showed during the source coge generation not in runtime

      Giorgio Bravi
      Dolphin Software & Thinkware


      • #4
        I pushed the issue through. Hope that will help.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development /


        • #5
          Hello Giorgio,

          This problem began to occur after an update Scriptcase or had never worked correctly?
          If possible, please send us your application just to look at how you are performing this exchange connections.

          Best Regards,
          John L. Santos

          Bug Tracker Team
          NetMake - IT Solutions


          • #6
            Hi John

            A ticket is already open ( XGZ-466-43333 from 15 nov 2013 ) and verified from the support team. As usual i've created an account for you ( SC ) to test projects.

            Ask to support team. The connection is still open. I've created a simple form to test.

            FYI the problem occur for both new and old ( also migrated from sc6 ) application and for sure worked in the past.
            Giorgio Bravi
            Dolphin Software & Thinkware