Announcement

Collapse
No announcement yet.

Form missing Insert Update and Delete buttons defined using Tools menu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Form missing Insert Update and Delete buttons defined using Tools menu

    I am not sure how or why but I had this problem before and went away but now is here again. I have a form and on the form Layout --> Settings I choose to use the Scriptcase 7 Black template and for some reason when the form displays the Insert, Update and Delete buttons are not on the form but the "Return" button is on the form. On the Tools menu I do have these buttons set to be displayed on the form but somehow they are not there and I can't insert nor update records in the form, any ideas why the buttons are not there??.

  • #2
    I can believe I am the only one having this problem.
    Does anyone know what controls the buttons on the form, I would think that just be selecting the insert, update and delete buttons on the Tools Menu would take care of this but it does not. I edited some events just made simple change to some code, recompiled the form app and the buttons reappeared but they were there only for a minute, the next time I made another coding change on the ONVALIDATE event did something because the next recompile the buttons went away again so I am back to step-1.

    Does anyone at ScriptCase monitors the forum? and if they don't why have one.

    Comment


    • #3
      I have similar problem with the grid. The ADD button is missing despite the form is created from the menu without ant changes or modifications. I also have had this similar problem and at some pint it went away. To be honest I really do not know what is causing it.

      Arthur
      -----------------------------------------
      Arthur Klisiewicz
      dATA POINT SOFTWARE
      www.datapointsoftware.com

      Comment


      • #4
        I can remember having it once, but useually I don't spend much time to finding the cause and just create a new application. It might be helping you. There are so many checkboxes, menus and options. In general if you do create a new form use a different name as I have found out that sometimes the bug will not go away. I.e. if you set a global variable in your db defines (force value) then undo the force value the field will go away. But internally the global persists and you get errors. Then if you run through all the options then you will not find it until you check the checkbox again. There are more of those.

        If you create a new application and same issue appears then there something broken in your installation I guess as this is a commonly used feature. A re-install might be the solution.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Albert I tried both: reinstall SC8 and generating with different names, none of them worked :-(

          Here is something interesting I discovered. I created new project, connected to the same database, then created the same 2 Apps (GRID + FORM) using Batch wizard and it works, and the buttons are in place. Now I'm pulling my hair out on what is causing it. IT seems that the Whole project got messed up or something. Any idea ?

          I would probably try to export the project then re-import it however my Export feature returns Error, so I cannot use it.

          Art
          Last edited by aka; 02-19-2015, 03:39 AM.
          -----------------------------------------
          Arthur Klisiewicz
          dATA POINT SOFTWARE
          www.datapointsoftware.com

          Comment


          • #6
            I have same problem: http://www.scriptcase.net/forum/show...-Form-Critical

            SC should do something for that. It's could be about cookies or permissions but it is a bug. I have a form for just adding new requests. And I just select "Insert" button on the form. But there is no button when I try to send the link to someone else. The button's visibility is turning to false, it's about the back php codes that SC generate. Some variables should have 'novo' value but they don't and I don't know why.

            So I just found this way to shown my buttons but I don't trust this way, I should not need those codes!

            On the ApplicationInit:
            sc_apl_conf("requestform", "start", "new");
            sc_apl_conf(requestform, 'insert', 'on');
            sc_apl_conf("requestform", "add", "on");

            ---

            If you have a control app that could be about permissions even you gave the right permissions the user...

            on the control app's OnValidateSuccess:
            sc_apl_conf(form_add_newTask, 'insert', 'on');
            Last edited by sekr; 02-19-2015, 04:43 AM.

            Comment


            • #7
              sekr - it seem that this problem affects only existing projects at some point. Try to create completely new project and few Apps and see if you missing any buttons. I'm not sure what is causing it but it did happen to me several times and it is terribly anoying. I will kee in mind your macro suggestion but doing this for every form seems insane

              Art
              -----------------------------------------
              Arthur Klisiewicz
              dATA POINT SOFTWARE
              www.datapointsoftware.com

              Comment


              • #8
                In general I think, if you have a problem in your application and cannot fix it in a relatively short time you should consider recreating the application * under a different * name. It useually is much faster than tracing the one and only bug, checkbox of other config. But can be frustating sometimes.
                Albert Drent
                aducom software netherlands
                scriptcase partner, reseller, support and (turn-key) development
                www.scriptcase.eu / www.scriptcase.nl

                Comment


                • #9
                  Albert- in my case every new App I created was causeing the same problem. I DID RESOLVE THE PROBLEM through workaround, but the internal SC issue still remains.
                  What I did was:
                  1. exported all Apps to a ZIPed file
                  2. re-imported all Apps to a new project (under different name)
                  3. From that moment everything started working as expected, however this whole procedure added about 8 extra hours of my work, simply because new Project was missing lots of settings, connections were not imported, field types were not imported and I also had to recreate a dictionary. another words it works now but I discovered that the problem was somewhere between SC and the Project. In general SC is doing terrible job as far as cleaning after itself. It is enough ht look at SC uninstallation process.
                  I'm glad at least I discovered where "the bad magic" happens.

                  Arthur
                  -----------------------------------------
                  Arthur Klisiewicz
                  dATA POINT SOFTWARE
                  www.datapointsoftware.com

                  Comment

                  Working...
                  X