Announcement

Collapse
No announcement yet.

Master/Detail form issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Master/Detail form issue

    hi guys, this is related to this thread http://www.scriptcase.net/forum/show...-clause-change
    as you can see, the idea there is going different, so decided to create a thread to explain it and show my error, perhaps you've been through it and can advise

    i have a grid that is having global variable [vcoll] to filter that data that being displayed using WHERE [vwhere] or just imagine it WHERE [vcoll]

    [vcoll] is set to "In" and if open the grid alone, it asks for a value... if typed manually e.g. '1' it filters the grid and shows like the grid where clause is WHERE coll_id=1 that is fine... if 0 is added (which is the default) it will show all records of the grid.. that is perfect...

    now, created simple entry form application... 2 blocks... removed all fields... added one virtual (sc field) to block1 and named it {select_coll} with manual values 0,1,2,3.. default is 0 and reload if field value changed (all as per instruction of the kind jsb)

    created the link of master/detail.. added the detail "calling the grid applicaton" to second block.. but when form is loaded there is nothing is sowed in block2 at all, only the title of the block.. the grid is not displayed at all!

    - the field is maped ok... [vcoll] variable is mapped to select field of the form
    - gird is working fine with ready to receive the var [vcoll]

    this is supposed to load the form, and select_col field control the vcoll variable.. but nothing displayes.. no indication of anything.. don't know why or what is wrong...

    any hint?


    i am using sc7, i don't think bugs are there like in sc8


    Mike
    Last edited by MikeDE; 10-02-2014, 02:48 PM.

  • #2
    nobody!?!!

    Comment


    • #3
      Create an export of the project with a sql file to share
      /Giuseppe

      Professional Scriptcase Services
      Some Customers opinions

      Comment


      • #4
        you are right brother, best to see

        here are the files
        https://www.dropbox.com/s/bacwdinhy2...sktop.zip?dl=0


        using latest sc7 version - my version is ok, db is mysql

        there is single record form "index_to_select_where_clause" this is supposed is giving the value of [vcoll] to the grid as master/detail

        seems pretty logic, don't know why doesn't work

        if you open the grid alone, it will ask for [vcoll] value and if you put a number it will and make the where clause like where coll=1 or 2 or 3... if 0 then all collections are displayed... but if try to pass the variable as parameter from from to grid, it doesn't show up, nothing...

        what could be i am missing?

        note: i tried making the select field of the form "manual" and added values 0,1,2,3 as manual numbers.. same issue, also if automatic from coll table



        Mike

        Comment


        • #5
          hmmm to update this thread, i could thankfully with Albert Aducom help re-create a new form as Master/Detail based on the same table of the grid.... the grid now shows but in iframe and NOT be controlled to show 100%, it works if you define the iframe as px, which tights the move, don't know how many records will retrun in each collection, and scrollbar isn't lovely...

          add to that a strange behevrious as the where calsue starts with inital error value then it works if select field is changed... but also returns wrong data.. i'm sure that there is something wrong yet still trying with it...

          moroever, i found this macro sc_select_where

          http://www.scriptcase.net/docs/en_us...c_select_where

          can't we use it for this!!?! just a grid, without a master/detail.. don't know how to apply it, tried all possible ways and ended up pulling my hair
          i just want to filter the records based on another where caluse within the same grid

          Comment

          Working...
          X