Announcement

Collapse
No announcement yet.

nm_atualiza('alterar') updates no more than 34 records

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • nm_atualiza('alterar') updates no more than 34 records

    Hullo. thank you for helping me

    I have an editable grid, with 39 students with their califications. And a Javascript Button with nm_atualiza('alterar');

    I found out that if I have less than 35 students, the app works perfect. But if I have 35 or more, it does not update any more.

    It works ok in development mode with any number of students. But the problem is in production mode. Even in my local mysql-php environment as in hosting environment.

    Anybody can help about how can I solve the problem?

    Thank you very much

    Prof. Sergio Rassino

  • #2
    I'm not sure, but what I could think of is that the allowed running time of php might be different in sc as in your php.ini used in your production environment. If you have too much students the amount of time used by php might be longer than allowed. Just u wild guess btw.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Thank you Albert for your quick reply.
      I tried increasing these values in my php.ini

      max_execution_time = 240
      max_input_time = 120
      max_input_nesting_level = 128
      memory_limit = 256M

      and have no results. (all values are double than previous)

      Some more info:
      - When I press Save Califications, the app takes only 1 seconds to show an empty grid, thats to say that it saved nothing and reload the previos page with no califications.
      - I have enabled to show errors in the app, and I can see sql sentences that are executed, but no error. Is there any way to make the app tell me which is the problem with the update?

      Any more ideas that could open my mind to continue searching?

      Thank you for your grate work

      Sergio

      Comment


      • #4
        Albert, I found the problem looking around your information.
        I looked in the log files and found in the apache_error.log the following:

        Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini

        so I added in the php.ini,

        max_input_vars = 2000

        and everyting goes ok now.

        If it helps someone, there it is

        Thank you for your help

        Prof Sergio Rassino

        Comment

        Working...
        X