Announcement

Collapse
No announcement yet.

Need clickable icon in Multiple Record form

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need clickable icon in Multiple Record form

    I need to grid in which each data line will have multiple URLs to click on.
    I started using a GRID which worked fine -- I got clickable icons that opened a new tab with the correct url.
    Here's how it looked:
    grid.PNG

    However,I realized I needed to add an input field. When I switched to a Form (Multiple Records, Editable grid or
    Editable grid view), it didn't work. Instead of displaying the icon, it displays the html code.

    Here's what the form looks like:
    form.PNG

    For the Grid, I did:
    OnRecord
    {home_url} = '<a href= "'.{home_url}.'" target="_blank" ><img src="path/home.png" style="width:24px;height:24px;border:0"></a>';


    For the Form, I did:
    OnLoadRecord
    {home_url} = '<a href= "'.{home_url}.'" target="_blank" ><img src="path/home.png" style="width:24px;height:24px;border:0"></a>';


    Please help. What am I missing?

  • #2
    Originally posted by tunester7 View Post
    I need to grid in which each data line will have multiple URLs to click on.
    I started using a GRID which worked fine -- I got clickable icons that opened a new tab with the correct url.
    Here's how it looked:
    [ATTACH=CONFIG]1688[/ATTACH]

    However,I realized I needed to add an input field. When I switched to a Form (Multiple Records, Editable grid or
    Editable grid view), it didn't work. Instead of displaying the icon, it displays the html code.

    Here's what the form looks like:
    [ATTACH=CONFIG]1689[/ATTACH]

    For the Grid, I did:
    OnRecord
    {home_url} = '<a href= "'.{home_url}.'" target="_blank" ><img src="path/home.png" style="width:24px;height:24px;border:0"></a>';


    For the Form, I did:
    OnLoadRecord
    {home_url} = '<a href= "'.{home_url}.'" target="_blank" ><img src="path/home.png" style="width:24px;height:24px;border:0"></a>';


    Please help. What am I missing?
    Did you set the field in form as image html?
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      Field Settings: Attribute 'Label Field' -> Yes

      jsb

      Comment


      • #4
        Setting the Field to "Label Field" did the trick!

        Thanks so much.

        Comment

        Working...
        X