No announcement yet.

[SOLVED] Document (Filename) Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Document (Filename) Problem


    Maybe I'm missing something, but I just can't get this to work so thought that I should ask...

    We have a requirement in one of our grid applications to show a pdf for each record which the user can click to view. I have added a varchar field to our table to store the pdf filename and set the field type on the grid to be Document (Filename). I have left the "subfolder" field blank. For testing purposes I have set all records in the table to point to a single file called test.pdf.

    No matter what I try when I upload the grid application I get the message "The file does not exist: test.pdf". It does work however if I run the application locally and place the test.pdf into the folder C:Program Files (x86)NetMakev5wwwrootscriptcasefiledoc.

    I have also tried deploying the application using the advanced deployment option and setting the documents folder to /_lib/file/doc, but this does not work either. I have tried placing the test.pdf file in the /_lib/file/doc folder, in the root folder of the site and a few other places as well, but as yet no joy.

    Does anybody have any suggestions?


    Mike Wilcock
    TSM Limited

  • #2
    Re: Document (Filename) Problem - Solved.


    Managed to sort this. I used the advanced deploy option but deleted all text from the documents folder path. This then seems to force the default /lib/file/doc folder.


    Mike Wilcock
    TSM Limited


    • #3
      Re: Document (Filename) Problem

      I have similar need (except I need MP3 files). I would really like some one from NetMake to give us some hints...



      • #4
        Re: Document (Filename) Problem

        I have the same problem

        someone has solve it ??

        thank's max


        • #5
          Hi MXSX,
          You can show a link file in a grid application using scriptcase. Following these steps:
          1. Make sure that your grid application is using a 'Documment file name' field. And 'Subfolder' in general settings of the field is empty.
          2. Clear the value of 'Documents Path' in your Grid>Application>Settings
          3. Make sure that your files exists in your production server /production_folder/_lib/file/doc/
          4. Deploy your project using the following values in advance mode:

          Example of production server directory:

          Your values in the deploy wizzard should be:

          Common Libraries Folder = /production_folder/_lib/prod
          Images Folder = /production_folder/_lib/file/img
          Temp Folder= /production_folder/_lib/tmp
          Documents Folder= /home/hosting/public_html/production_folder/_lib/file/doc

          Note: Your documents folder needs to be an ABSOLUTE path.
          Last edited by hirambq; 01-28-2013, 12:00 AM.
          Best Regards
          Hiram BQ


          • #6
            Hi all,

            I'm doing several tests but I've still problems with advanced deploy.
            If I do the adv deploy you also then have to download common files/libraries (zip) . Then once unzipped you will have to add these folders under /_lib/
            In this way I loose on production side all folders and files that locally are under file/img or file/doc .
            Is it correct or am I wronging or jumping a step ?
            The only way seems to it manually but I don't like it becouse it's time consuming and also no-errors proof .
            Any suggestions will be very appreciated.