Announcement

Collapse
No announcement yet.

V7 what has to be set-up to export to PDF ???

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • V7 what has to be set-up to export to PDF ???

    Tested the pdf-export on V7.

    Within the programming enviroment, everything is working fine.

    When I uploaded the application to a production server, the pdf file, which should stored in the tmp directory is not found. There are only corresponding .css .html and .log files in. These files have a matching timestamp and a matching name, as it should be, but there is no pdf-file ...

    Are there some additional requirements for the pdf-export to set up on the production server?

    Best regards

    Eric
    Last edited by EricB; 02-28-2013, 11:43 AM.

  • #2
    Are you trying to export a PDF file from a Grid application?

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Hi Bernhard,

      I built a small grid and tried to export to pdf. Both, view and download did not work, cause in the tmp directory only had .css, .html and a .log file.

      Tested it on the programming enviroment. Here it worked, the pdf file was written, which also was shownnin the dialog window.
      On the production enviroment, the pdf writing was not mentioned, directly jumped to export finished comment.

      Best regards

      Eric

      Comment


      • #4
        Hello Eric,

        I have just reported that to our bugs team, although I believe that issue might be happening due to your prod. environment configurations.

        Also, have you checked if write permission has been set to the folder (you said that the other files were generated, but just to make sure)?

        regards,
        Bernhard Bernsmann

        Comment


        • #5
          Hi Bernhard,

          thank you for reporting that to the bug team. I was not sure if that is a bug or just an additional necessary configuration of the production enviroment.

          Yes, the other files are written in that folder, same as other documents, which are stored temporary there, documents, pics etc ...

          Best regards

          Eric


          P.S. Tested on another webserver, same result ...
          Last edited by EricB; 02-05-2013, 06:50 AM.

          Comment


          • #6
            Originally posted by EricB View Post
            Hi Bernhard,

            thank you for reporting that to the bug team. I was not sure if that is a bug or just an additional necessary configuration of the production enviroment.

            Yes, the other files are written in that folder, same as other documents, which are stored temporary there, documents, pics etc ...

            Best regards

            Eric


            P.S. Tested on another webserver, same result ...
            It might be related to the web server configuration. I'm not sure.

            If it is a configuration issue, our support should now.

            Edit: Eric, please check if you have set read, write and execute permission to "scriptcase\prod\third\wkhtmltopdf". And let me know on that.

            regards,
            Bernhard Bernsmann

            Comment


            • #7
              Dear Bernhard,

              I set the permission from 755 to 777 and I can report it is working ...

              Thx

              Eric

              P.S.: Now I also tested a grid with more than one table and it is NOT generating the pdf, but all the other files. Export to other formats, doc or xls, it is working fine with more than one table. In forms and grids with one table it is working very good.
              Last edited by EricB; 02-06-2013, 06:55 AM.

              Comment


              • #8
                Originally posted by EricB View Post
                Dear Bernhard,

                I set the permission from 755 to 777 and I can report it is working ...

                Thx

                Eric

                P.S.: Now I also tested a grid with more than one table and it is NOT generating the pdf, but all the other files. Export to other formats, doc or xls, it is working fine with more than one table. In forms and grids with one table it is working very good.
                Some of our Brazilian users are having the same problem.

                Comment


                • #9
                  Eric,

                  After a few tests our bugs team confirmed that it is a bug.

                  That issue is usually happening when a margin is set on PDF export. We working to fix it, and it should be out on our next release.

                  Thanks for your feedback and patience.

                  Bernhard Bernsmann

                  Comment


                  • #10
                    OK, now I am on 7.00.0003 and tested it on two different webserver and the programming enviroment.

                    It still does not work without correctly.

                    Programming enviroment, pdf is shown as it schould be.
                    Other webserver, each webserver stopps the pdf-creation at a different position and shows the result after stopping with the comment:

                    Fehler beim Erstellen der PDF-Datei. Kontaktieren Sie den Techischen Support. // Error when creating PDF-file. Please contact the technical support.

                    Each webserver stopps the creation allways at the same position on that webserver, but every webserver at another position, compared to the other one ...

                    BR

                    Eric


                    P.S. Now it does not matter, how the folder/files permission are set ... 755 and 777 have the same result
                    Last edited by EricB; 02-24-2013, 05:20 AM.

                    Comment


                    • #11
                      Thank you for your feedback. Other users are experiencing the same issue. Our bugs team is analyzing the issue.

                      regards,
                      Bernhard Bernsmann

                      Comment


                      • #12
                        Hello Eric,

                        I just got back an reply from our bugs team. The issue was happening because a few files at prod/third/wkhtmltopdf were corrupted. As you already are able to generate PDF (on dev. environment), you should be able to do the same on production environment. Please check if there are any files under prod/third/wkhtmltopdf on your deployed project. I was going to ask you to set 755 or 777 permission to the folder, but from what I can tell you already did.

                        Sorry for asking you the same thing again, but the working file was only added on our last release.

                        regards,
                        Bernhard Bernsmann

                        Comment


                        • #13
                          Hi Bernhard,

                          I gave it a try. Deleted the whole installation. Generated and deployed the whole story to the webserver. Checked that folder wkhtmlopdf for permissions, it had 777. BUT unfortunally I got directly the information "Fehler beim Erstellen der PDF-Datei. Kontaktieren Sie den Techischen Support." No difference ...

                          BR

                          Eric

                          Comment


                          • #14
                            Hello Eric,

                            Thanks again for your feedback. I will report that to our bugs team.

                            regards,
                            Bernhard Bernsmann

                            Comment


                            • #15
                              Hello Eric,

                              Two things.

                              1 - The PDFs that aren't being generated are from GRIDs that has any GROUP BY, or does it happen to any sort of grid?

                              2 - Some of our brazilian customers were able to solve the issue with a quick hint from our bugs team.

                              Both are working on linux, the first one had to install libxrender1.so on his environment (sudo apt-get install libxrender1)

                              The second found out that he wasn't able to generate PDFs because he hadn't set EXECUTION permission to /prod/third/wkhtmltopdf/linux-amd64/wkhtmltopdf-amd64

                              regards,
                              Bernhard Bernsmann

                              Comment

                              Working...
                              X