No announcement yet.

Thumbnail Regeneration

  • Filter
  • Time
  • Show
Clear All
new posts

  • Thumbnail Regeneration

    Hi All!
    We're working on a simple grid application which required that we move it to a production environment
    This grid has images in one column set up as file images (not database)

    The images appear fine in the original application but return 404 in the new situation.
    When we inspect the image link we find it is looking for thumbnails in the ../_lib/tmp directory

    However these thumbnails are not there -- not regenerated yet.

    How to regenerate the thumbs or force the app to load the orginals
    Have checked file system permssions

    An ideas welcome!
    Thanks very much

  • #2
    hi prema,

    did you find a solution for this? i have the thumbnail looking in my grid only black color and ugly!


    • #3
      Did you configured tmp folder on production environment? Has you permission on this folder?

      Professional Scriptcase Services
      Some Customers opinions


      • #4
        hi Giu, no, i found that difficult dear, so i storred them in the database wish i can manage to upload them to a folder now the thumbnails sometimes look black, and if clicked show only half of the image... can't load the full image to view it! don't know why, i have the gd library in php.ini enabled


        • #5
          okay, i could manage to make it as Image-filename and i put the subfolder name as "upload" and it seems working but really have no idea where the file actually is storred!? also how about if you ahve 2 o 3 uploaded files each one want to make it upload limit different!? there is only one upload limit which is tricky and i couldn't manage to make it work as required yet (from application side left down, it seems calculated in bit, not mb)

          one more thing, how i can make the file to be renamed automatically when uploaded to the storage folder?
          also, if i want to send a record that have a file of this type (image database or image filename) by email? how to make it go with the email as attachment? do you think this is possible?



          • #6
            so far could manage to send email with SMTP (after big help from EricB) but yet trying to make this image file-name to send along as attachment but couldn't

            i am trying from localhost, the file path is scriptcase/file/imgimages2 and the file name is {image2}


            tried also all with leading dot "." before the {image2} like 'xxxx/xxxxx/'.{image2};

            no use