Announcement

Collapse
No announcement yet.

Grid error - moving to next page takes a long time

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grid error - moving to next page takes a long time

    Here is the error I get on a grid that accesses a table with 91 records with number of records set to 50. This error appears at the top of the page when going to next page.

    Fatal error: Call to a member function monta_res_grid() on a non-object in C:\Program Files (x86)\NetMake2\wwwroot\scriptcase\app\ProTrack\gri d_project_main\grid_project_main_grid.class.php on line 223

    Also whenever I click on show all records the grid just hangs while displaying the "processing" icon.

    Anyone have any ideas?

  • #2
    Originally posted by chersey View Post
    Anyone have any ideas?
    Yes ...

    Originally posted by chersey View Post
    Fatal error: Call to a member function monta_res_grid() on a non-object in C:\Program Files x86)\NetMake2\wwwroot\scriptcase\app\ProTrack\grid _project_main\grid_project_main_grid.class.php on line 223
    Which code is on line 223? Post it please ...

    Have you a grid with name "monta_res_grid" in your project?
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

    Comment


    • #3
      Hello,

      Do you have any custom code on the application? If so have you tried to comment the code to see if the issue continues?

      Creating new simple grid (w/o) modifying anything causes the same error?

      regards,
      Bernhard Bernsmann

      Comment


      • #4
        Here is the code:

        212| if ($_SESSION['sc_session'][$this->Ini->sc_page]['grid_project_main']['opcao'] == "pdf" && $_SESSION['sc_session'][$this->Ini->sc_page]['grid_project_main']['SC_Ind_Groupby'] != "none")
        213| {
        214| $this->Res->monta_html_ini_pdf();
        215| $this->Res->monta_resumo();
        216| $this->Res->monta_html_fim_pdf();
        217| }
        218| else
        219| {
        220| if (empty($this->nm_grid_sem_reg))
        221| {
        222| $this->Res->monta_res_grid();
        223| }
        224| }
        225| }

        No grid named "monta_res_grid". The grid is named "grid_project_main".


        Also I removed everything from the Events and still have the same error.
        Thanks
        Last edited by chersey; 08-11-2013, 10:51 AM.

        Comment


        • #5
          Hello,

          Issue reported to our bugs team.

          regards,
          Bernhard Bernsmann

          Comment

          Working...
          X