Announcement

Collapse
No announcement yet.

Scriptcase video samples are fake!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scriptcase video samples are fake!

    The tutorial at -> http://www.scriptcase.net/scriptcase.../#dynamic-menu Doesn't even work! Here is my code
    Code:
    sc_appmenu_reset(menu);
    sc_appmenu_create(menu);
    
    sc_lookup(dsmenu, " SELECT
    					id, 
    					parent, 
    					description, 
    					link 
    				FROM 
    					menu_link
    				ORDER BY 
    					parent,
    					node_order");
    
    foreach ({dsmenu}  as   $arr_menu)  {
    	$id_item = 'item_'.$arr_menu[0];
    	
    	if ($arr_menu[1]  ==  0) {
    		$id_parent = '';
    		}else{
    		$id_parent = 'item_'.$arr_menu[1];
    		}
    
    		
    sc_appmenu_add_item{
    	'menu',
    		$id_item,
    		$id_parent,
    		$arr_menu[2],
    		$arr_menu[3],
    		"","","",""
    		};
    This is verbatim from the tutorial minus the table name. I have a table set up just like the one in the example. When I run the menu it's blank. I can take out the foreach and it runs but with no menu items. As soon as I put in the code Scriptcase supplies it doesn't work. It would help if this was explained a little further or an actual example with working code. It's pretty worthless to create a video on an example that doesn't exist and the code doesn't even work.
    Last edited by ancr2001; 03-31-2014, 10:52 AM.

  • #2
    Hello

    This is Marcia from Scriptcase Sales Department, i was the one who did the live webinar on this topic. May i ask you please to send me your contact by email (marcia@scriptcase.net) in this way i will be able to help you with the assistance of a technical support operator. The code looks ok, same as we did in the example, we need just to check the all thing and find our what is wrong there. I will look forward to your contact. Thanks.

    Comment


    • #3
      Hello again,

      I just found something wrong, maybe this is the reason. You are using the macro sc_appmenu_add_item with {}, the correct is with ().
      Wrong way: sc_appmenu_add_item{};
      Right one: sc_appmenu_add_item();

      We have also this video that may help you: http://www.youtube.com/watch?v=8nUacFw1yMY
      Tutorial: http://support.scriptcase.net/index....a-dynamic-menu

      Comment


      • #4
        Not agreeing with either post above, one needs help, other want's polite!, but nothing works with unpolite or polite requests or issues posted on this forum, Scritpcase pretty much ignores these posts. I have 2 old issues that has never been looked at and both are show stoppers. The Scriptcase video where multiple search fields are used on a Search screen stops right after the multiple search fields are defined and only use one field to display the results on the grid I did not see the use of more than one field on a search panel and that is my problem. I have one search where I need to select records using multiple search criteria but it does not work not does Scriptcase has responded to this issue I only got the "bug reported to our development team" which translates to a "black hole" where bugs fall into and never come out of.

        This might not seem polite to some but no responding or addressing bugs reported, issues, questions, ignoring the people that are investing money and time using Scritpcase weather we are paying support or not, not sending noficiations as to where are the bugs or issues reported is not polite either.

        Comment


        • #5
          Have you actually opened a ticket - or even tried the online chat? That's worked well for me - especially the latter as you get largely an instant response. It's not online 24 / 7 but seems to be on around Brazil's working day.

          Comment

          Working...
          X