Announcement

Collapse
No announcement yet.

MENU works in localhost, not in production

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MENU works in localhost, not in production

    top level menu items show in production, the lower level menu items do not show.

    every menu item (top/lower) shows/works in localhost perfectly.

    deployed zip to production, unzipped (ubuntu/ruby environment) used ~/current/public/scriptcase-directory/zipped.zip
    any suggestions/help is appreciated.

    john

    its like getting onto atlanta 285 freeway and never getting off...

  • #2
    Originally posted by johnweimer View Post
    top level menu items show in production, the lower level menu items do not show.

    every menu item (top/lower) shows/works in localhost perfectly.

    deployed zip to production, unzipped (ubuntu/ruby environment) used ~/current/public/scriptcase-directory/zipped.zip
    any suggestions/help is appreciated.

    john

    its like getting onto atlanta 285 freeway and never getting off...
    I think that in the development environment you have disabled security for debugging purposes. Go to options -> myscriptcase and set both checkboxes. Then the development environment will work as the prod env and you are able to test your issues.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Originally posted by aducom View Post
      I think that in the development environment you have disabled security for debugging purposes. Go to options -> myscriptcase and set both checkboxes. Then the development environment will work as the prod env and you are able to test your issues.
      thank you for quick response, i set both check boxes on localhost.
      also looked at generated php code and the lower level menu items are there.

      tested and the same issue now exists on localhost development!!!

      will add security login module and see if that brings the lower level menus out...

      Comment


      • #4
        Then you have likely set the security option on your application(s) to on. That will require you to use macro's to allow access or to use a security module. You can omit this if you unset the checkbox at the security entry for your application.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Originally posted by aducom View Post
          Then you have likely set the security option on your application(s) to on. That will require you to use macro's to allow access or to use a security module. You can omit this if you unset the checkbox at the security entry for your application.
          i removed all security module code from application.
          watched Scriptcase 6 - Creating a login application http://www.youtube.com/watch?v=7bz_Azyvyu0
          coded "login/control" application as per video
          "Options/My Scriptcase" unchecked both boxes
          tested localhost - all menus accessible thru login control application

          deployed zip file to ssh server and unzipped
          accessed "login/control" thru browser and got this message:
          Connections Create
          The database connection that your application use was not found. You need to access the production environment and create the connection.
          Connections not found: conn_mysql
          Click here to create the connections now.

          followed instructions and connected with database successfully, saved and went to another browser and
          tried again and same error.

          so close but yet so far.

          Comment


          • #6
            Originally posted by johnweimer View Post
            i removed all security module code from application.
            watched Scriptcase 6 - Creating a login application http://www.youtube.com/watch?v=7bz_Azyvyu0
            coded "login/control" application as per video
            "Options/My Scriptcase" unchecked both boxes
            tested localhost - all menus accessible thru login control application

            deployed zip file to ssh server and unzipped
            accessed "login/control" thru browser and got this message:
            Connections Create
            The database connection that your application use was not found. You need to access the production environment and create the connection.
            Connections not found: conn_mysql
            Click here to create the connections now.

            followed instructions and connected with database successfully, saved and went to another browser and
            tried again and same error.

            so close but yet so far.
            any help is greatly appeciated

            Comment


            • #7
              production deploy issues

              to review where i left off:
              i removed all security module code from application.
              watched Scriptcase 6 - Creating a login application http://www.youtube.com/watch?v=7bz_Azyvyu0
              coded "login/control" application as per video
              "Options/My Scriptcase" unchecked both boxes
              tested localhost - all menus accessible thru login control application

              deployed zip file to ssh server and unzipped
              accessed "login/control" thru browser and got this message:
              Connections Create
              The database connection that your application use was not found. You need to access the production environment and create the connection.
              Connections not found: conn_mysql
              Click here to create the connections now.
              followed instructions and connected with database successfully, saved and went to another browser and
              tried again and same error. (it said saving but did not seem to work)

              changed directory permissions on _lib to 777 and re-entered connection parameters (directories should be set back to 755 - find . -type d -exec chmod 755 {} \
              copied over from development box sec_users, sec_groups, sec_apps, sec_groups_apps

              bingo, touchdown, score the big one, finally made it into production !!! wow life is good again

              thank you all

              Comment

              Working...
              X