Announcement

Collapse
No announcement yet.

Deployment on Ubuntu Linux host

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Deployment on Ubuntu Linux host

    Can anyone direct me to a reference to deploying a ScriptCase application on an Ubuntu Linux Host to ensure all dependencies are correctly met as a base LAMP installation does seem to miss some? In addition to that ensuring that there is the right version of PHP would certainly be of help!!

  • #2
    Originally posted by bengrech View Post
    Can anyone direct me to a reference to deploying a ScriptCase application on an Ubuntu Linux Host to ensure all dependencies are correctly met as a base LAMP installation does seem to miss some? In addition to that ensuring that there is the right version of PHP would certainly be of help!!
    Afaik, there's nothing special, I never encountered issues while deploying on linux servers. It's just a matter of uploading the whole lot to your server under the apache root. Depending on your wamp you might have to fiddle with php runtime limits, memory, but I never had to. Better way is just to deploy and report issues here (if any). I deployed it under standard WAMP like Wamp, uniform etc. and never had issues.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Thanks for the feedback, as I already tried this and Scriptcase Diagnostic is reporting Zend module missing as attached.

      ScriptCase_Zend.png

      Any solutions to how this can be added?

      Comment


      • #4
        Edit your php.ini file and add the zend module in it. You'll find enough info on the web on how to do this.
        Also you should check if there even is a zend extension file available.

        Comment


        • #5
          What is the package that has to be installed Zend Framework?

          Comment


          • #6
            Originally posted by bengrech View Post
            What is the package that has to be installed Zend Framework?
            Do you have a fully updated Scriptcase? Afaik, you don't need any zend stuff to be installed separately. The first deploy must be full including _lib.
            Albert Drent
            aducom software netherlands
            scriptcase partner, reseller, support and (turn-key) development
            www.scriptcase.eu / www.scriptcase.nl

            Comment


            • #7
              Thanks Aducom, performed clean deployment and worked fine!

              Comment

              Working...
              X