No announcement yet.

How to Deploy applicaiton using a MAC P.C. on a Local Directory

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to Deploy applicaiton using a MAC P.C. on a Local Directory

    I am using a MAC P.C. to develop scriptcase application to a LOCAL directory I don't have a serve to FTP at this time and I am having problems completing the deployment process.

    First try:
    I first deployed the application using a zip file and a local directory
    For directory I entered /Developer
    Deployment gave a huge amount of erros loading images and templates but completed creating a file called
    A link appears after the zip file is created that says "click to download"
    I clicked the link and the zip file was downloaded to my Downloads folder but I expected it to be downloaded to the selected folder but is not the case.

    NOTE that the zip file is not zipped is a straight folder with all the application files ????
    I copied the zip file to the Developers folder
    Gave the permissions needed
    Open the web browser and enter the following: http://localhost:85/project_1/_lib but it does not work it goes nowhere....

    Second Try:
    Deleted the first zip folder and deployed again this time to a folder withing /Applications/NetMake/v7/wwwroot/
    I get the following results:
    This deployment creates the same contents as the zip file but on this folder: /Applications/NetMake/v7/wwroot/ .... (all files on the zip file are here - this seems wrong !!!).
    Next I copied the new zip folder to the wwwroot/project (note is not a zipped folder)
    Gave all the permissions to the folder
    Open the web browser again this time with : http://localhost:85/project_1/_lib --- >>> same results it does nothing.

    Can anyone help with mac deployment to a local directory???
    Last edited by javierx1; 06-06-2013, 04:31 AM. Reason: Solved

  • #2
    I don't have (much) experience with mac, but first of all you should not deploy on the scriptcase server imho. You could consider to install a wamp package on your mac, like

    Then deploy to the www folder of this package. It's the way it's working on windows, I expect it should work similar on mac this way, running under standard http port (localhost)
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development /


    • #3
      Thank you for the reply Albert,
      I just migrated Scriptcase from a windows p.c. onto a MAC p.c. so I don't have to deal with to p.c's all the time and
      I have been thru hell getting Scriptcase to work on a MAC pc and finally I got it to work now I need to get thru the deployment process.

      I do have Parellels on my MAC but I don't really want to flip flap either at least for now.
      I thought they would have some documentation on how exactly deployment works, the video simply gives you a box to enter a folder name but does not tell you where the folder needs to be to get recognized by the browser.
      The video tells me to open the browser and enter this: http://localhost:85/project_1/_lib
      I tried it twice and nothing works.
      I hope somebody that has done this using a MAC can provide some input.


      • #4
        Why don't you install mamp, test standard port 80 and deploy directly on the www directory of the mamp installation? Have you checked if the 85 is actually used? If the ports in Mac are the same on pc then this is not correct. (86 and 97 for resp. SC6 and SC7)
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development /


        • #5
          How can I tell if 85 is valid or not do you know?


          • #6
            I know I had to change how I access scritpcase development using port 97 and local host like this which is not the same as the instructions:


            • #7
              Again, I don't know much about mac. If a port is used can be checked by pinging it. You changed the ports used? If you run apache on your mac, then look into htconfig to see on which ports the server is listening. Put a 'halloworld.html' in your webserver root. Does it appear or not? If not, then your webserver is not working or you need to use another port.It's a bit troubleshooting, but I can only try to give you some hints as I cannot check this. (Sorry ... :-(
              Albert Drent
              aducom software netherlands
              scriptcase partner, reseller, support and (turn-key) development


              • #8
                Thank you for your help.


                • #9
                  In your terminal type: lsof -i | grep LISTEN
                  This should show you all listening ports.
                  And depending on the osx version you may need to configure your osx firewall (check google for the how to's)


                  • #10
                    This post is now closed.

                    I seem to have resolved the issue and I am still waiting for Scriptcase support telephone call, they have not called yet.

                    Seems like for a MAC you can't use http://localhost:97/ProjectName, you need to use

                    The Project folder generated from the deployment process is not zipped on a mac is a straight folder unzipped, so I am going to call this: Project-1.
                    The folder needs to copied into: Applications/NetMake/v7/wwwroot/Project-1.

                    There is no documentation for a MAC and assuming all deployments work the same is incorrect and very time consuming.

                    Many thank you to all the guys that volunteered the time in providing suggestions.