Announcement

Collapse
No announcement yet.

Security problem Users could not Login to Production Environment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Security problem Users could not Login to Production Environment

    I created an application with security on group level, everything is good.
    when i export the application to the production environment, also locally on my Computer, Im not able to login any more !
    It is said: user is not allowed !
    I could see the whole menu structure, but i have no permission to check one !!
    I could try it with different users no one is working

    Any ideas ?

  • #2
    Do you have set the checkboxes in settings so that while developing the security check is disabled? If that is the case then set it to check and you probabely will not be able to logon to your development version too. Then you can debug to see what is going wrong. If this is not the case then I don't have an idea currently.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      No, tested visa-versa, not working !

      Comment


      • #4
        I know this sounds stupid

        But you did migrate the database data from development into production right??

        Kevin
        Last edited by Kdriscoll; 07-11-2013, 11:32 PM.

        Comment


        • #5
          Originally posted by Kdriscoll View Post
          I know this sounds stupid

          But you did migrate the database data from development into production right??

          Kevin
          no, the database is not migrated, i use the same in development as in production

          Comment


          • #6
            Have you synchronized the applications? Are the rights correctly set? Is there a default user/password to be able to enter? At least one user should be in the user table. Just a few shots which comes to my mind. Not sure if it's helpful.
            Albert Drent
            aducom software netherlands
            scriptcase partner, reseller, support and (turn-key) development
            www.scriptcase.eu / www.scriptcase.nl

            Comment


            • #7
              As i said before, the DB is the same in development and production, so i have users and the apps are synchronized

              Comment


              • #8
                Hello,

                Please contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm (GMT -3), and our ticket system is always available.

                regards,
                Bernhard Bernsmann

                Comment


                • #9
                  For me same problem. Is this issue solved? And if yes: how did you solve this issue?

                  Kind regards, Ernst

                  Comment


                  • #10
                    Same for me, same server, same database, but can't even sync applications.

                    Any solution?

                    Comment


                    • #11
                      I suspect that you haven't setup the default user right. I think you can solve the issue by setting all values in your sec_groups_apps to 'Y' by using sql. then you should be able to logon as admin and go to the security pages. There you can save and you will see that some unused checkboxes will be grayed out. Then you have a basic working situation you can work on.
                      Albert Drent
                      aducom software netherlands
                      scriptcase partner, reseller, support and (turn-key) development
                      www.scriptcase.eu / www.scriptcase.nl

                      Comment


                      • #12
                        I've solved, but I can't remember how

                        Comment

                        Working...
                        X