Announcement

Collapse
No announcement yet.

Deploy: Cannot change default "scriptcase" password - endless loop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    If you are evaluating scriptcase you can always make use of Scriptcase support. It's quality might not be good on every occasion but it's being improved significantly currently. I would advise you to use a live chat. Did you already tried to re-upload by the way? I have had this problem once and it solved my issue.

    Reinhard, my advise of apache was not meant as a discussion between IIS of A. I have ran IIS a long time and it's a very good webserver. But the issue currenlty is as far as I can see an IIS issue and not a Scriptcase issue. And as there are thousands of options to set in IIS it's like searching for the needle in the haystack and virtual impossible to answer with the limited information we have.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #17
      Originally posted by aducom View Post
      But the issue currenlty is as far as I can see an IIS issue and not a Scriptcase issue.
      Yes, it's a IIS issue ...

      I have setup an IIS 8 installation for @hkuersten and install one of my sc projects. I can't write the configuration (endless loop). But, i have searched at google and found a solution: Click! This solution is for wordpress, but with minimal changes (#12 - #17) my sc app is running on IIS 8 .
      Best regards: - Reinhard -

      I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

      Comment


      • #18
        >> Select Anonymous Authentication and in the Actions pane on the right side click "Edit"
        >> Then select "Application Pool Identity" and click OK

        That did it - Thank you so much Reinhard, you saved my day!
        That was indeed a hidden option, which I have never needed before...

        It would really help those... crazy & remote IIS admins and potential ScriptCase customers, if there was a help topic on IIS deployment somewhere

        Comment


        • #19
          Originally posted by hkuersten View Post

          That was indeed a hidden option, which I have never needed before...
          Which rests my case. But I'm glad that the issue is solved though.
          Last edited by aducom; 12-05-2013, 04:38 PM.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #20
            My relief was a bit too early - this deployment is turning out to be a bit of a horror for me :-(

            In the production environment I cannot connect to the mySQL database, even though in my dev environment I have no problem running my app.

            Untitled9.jpgUntitled8.jpgUntitled7.jpg

            Now what?

            Comment


            • #21
              No Connection could be made because the target machine actively refused it.
              Check the firewall on that machine ...


              P.S.: Please no horror storys, no "what the world is bad" and so on. Report only your problems with SC and we would look at this. Thanks!
              Last edited by RHS; 12-05-2013, 05:27 PM.
              Best regards: - Reinhard -

              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

              Comment


              • #22
                The target machine is a Windows 2008 R2 Server with mySQL and IIS7, serving port 3306. I can access it without problem with phpMyadmin and HeidiSQL, as well as with other PHP applications that are installed on my local Vista PC.

                In other words: other PHP applications on my local IIS7 Webserver can access the remote database, while the Scriptcase production environment cannot. This is the 2nd strange behavior of Scriptcase on my local IIS7 compared to other PHP apps that are running fine. I'm just repeating this to make the point, that it has apparently nothing to do with my setup.

                Just to make sure, I turned off my local Vista firewall, although this cannot be the problem. Other than that, there are no firewalls in between. And as I said, I can access the remote mySQL database with any other application.

                Again, what am I doing wrong?

                Comment


                • #23
                  Again, check your firewall on the server ... You can set it short (!) to off and can also enable a protocol on your firewall.


                  For me here is EOT, because I do not see that you are looking for solutions themselves.
                  Best regards: - Reinhard -

                  I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                  Comment


                  • #24
                    Look at your mysql connection setting. Which connection have you setup? PDO, transactional or nontransactional? I would start selecting the latest connection and retry. And yes, please stop pointing at scriptcase. This is *not* a scriptcase problem but an IIS problem. Have you tried to get into contact with Scriptcase support?
                    Albert Drent
                    aducom software netherlands
                    scriptcase partner, reseller, support and (turn-key) development
                    www.scriptcase.eu / www.scriptcase.nl

                    Comment


                    • #25
                      Ok, once again the facts:

                      - There is no firewall on my local PC (Vista with IIS7, PHP)
                      - There is no firewall on my remote database server (Windows 2008 R2 with mySQL)
                      - I am not deploying to my remote server, but my local IIS. The remote server only hosts the mySQL database.
                      - I can run all SC applications and access the remote mySQL database in the local SC development environment
                      - I can run any other local (PHP, HeidiSQL, phpMyAdmin) application and access the same remote mySQL database
                      - I cannot access the remote mySQL database from the local SC production environment

                      Details: In the production environment, after changing the password, I am redirected to the "new connection" form. There I have 3 choices: MySQL transaction, MySQL, MySQL PDO
                      I have tried all and am getting "Connection Error: Unable to connect: Connection attempt failed: SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it." I cannot edit any mySQL hostname, port, or any other option. So I am assuming that the connection string from the dev environment is used. So why does the dev environment running on the SAME local machine can access the remote database, but the production environment on the SAME local machine can't?

                      I am not pointing the finger anywhere - could be anything - but I have never had these problems with any other deployment before.
                      So once again I am asking if anyone has managed to get this running on a local IIS7 with a database on a remote server.

                      @ Reinhard: believe me, I am looking at every single possible solution since I started this thread 3 days ago, and you have helped me in getting past the passoword dialog, which was not an IIS issue but a missed configuration on my part. But at the moment I am totally stuck and have no idea what else I could be missing. Please look at the facts. From my point of view, I cannot see how this can be an IIS problem. Maybe I'm wrong, but that's why I am here.

                      @ Albert: yes, I have contacted the SC support, pointed them to this thread, but they asked some default question showing me that they didn't read the thread. So I am not getting very far there, but will try again if everything else fails.
                      Last edited by hkuersten; 12-06-2013, 07:35 AM.

                      Comment


                      • #26
                        Originally posted by hkuersten View Post
                        The remote server only hosts the mySQL database. [...]

                        [...] I cannot see how this can be an IIS problem.
                        I'am not say thats a IIS problem ... but a problem with your MySQL configuration on the remote server. Search with google after "No connection could be made because the target machine actively refused it." and you will find the solution (headwords: my.ini / localhost vs. 127.0.0.1 / lower case table names / etc.).
                        Best regards: - Reinhard -

                        I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                        Comment


                        • #27
                          I have re-read your post ...

                          Originally posted by hkuersten View Post
                          [...] I cannot edit any mySQL hostname, port, or any other option. So I am assuming that the connection string from the dev environment is used.
                          No, dev environment and production environment are not identical. When you can't edit the MySQL settings in production environment, you have not done all steps (#12 - #17) in my solution link for wordpress / IIS. Clarify that first please.
                          Best regards: - Reinhard -

                          I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                          Comment


                          • #28
                            If your mysql is is not running on your iis server then you have to run your iis as an elevated user. The standard iis user has no rights to go outside the iis dir and also no rights to do networking outside localhost. Of course you can also give the iis user those rights.. Check in your services if you are running as Local System, Local Service or Network Service or as a dedicated user.
                            Alternatively (I am talking about windows 2008 I dont have vista to check that here) go to your iis manager and chack your Handler mappings and test if you set it properly (it should be good if you installed php on iis using administrator rights). Also check te rights for your PHP_via_FastCGI handler.
                            You get this 'error the target machine refuses it' also if some of your rights are insufficient.
                            The best alternative tho is to ditch iis and grab uniform server since you can finetune your settings better in apache then with iis.
                            So the first step you do is that you make a small php program by hand and connect with your remote database (for example).

                            $link = mysql_connect('your_my_sql_servername or IP Address', 'user', 'password');
                            if (!$link) {
                            die('Could not connect: ' . mysql_error());
                            }

                            echo 'Connected successfully';

                            mysql_select_db('yourtable_here',$link) or die ("could not open db".mysql_error());
                            // we connect to localhost at port 3306

                            Only when you get that to connect, then you can proceed further testing with scriptcase.

                            And yes you can get it to work, I did it too..
                            O yes do check your php.ini output, it of course needs the mysql dll's running.

                            Comment


                            • #29
                              @rr: mysqli_connect, not mysql_connect, because @hkuerten use MySQL transactional.

                              But he probably has another problem, see my last post.
                              Best regards: - Reinhard -

                              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                              Comment


                              • #30
                                @ Reinhard:

                                # 12 & 13: done before I started this thread
                                # 14, 15, 16: done - thanks to your help it got me past the SC production password loop
                                # 17: done, see screenshot - no change

                                Untitled9.jpg
                                the connection dialog in my local SC dev environment. here I have normal access to the remote database

                                Untitled10.jpg
                                the cmd from #17

                                Untitled11.jpg
                                when I log into the SC production environment and choose mysql

                                Untitled12.jpg
                                when I press test connection

                                Comment

                                Working...
                                X