Announcement

Collapse
No announcement yet.

Can't choose Database Name in PROD environment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I am attaching the image for more clarity

    errorduringconnection.jpg

    Comment


    • #17
      I looked into MySqli also and it is supported in my current local environment. See the attached image from php_info(). I have installed php and mysql using XAMPP.

      mysqlisupport.jpg

      Comment


      • #18
        I have the same problem with PHP 5.4.20

        Originally posted by John L. Santos View Post
        Hello Mr. Igor,

        This problem occurs because the version of PHP 5.5 and not the version of MySQL
        This is just a warning message, but I do not know why Scriptcase is not listing databases.
        We are checking this problem.




        You can use PHP version 5.4 without problems.
        Hello John,

        I have the same problem with PHP 5.4.20, could you tell me when scriptcase think to resolve this bug. I'm right in the implementation phase of a project and this issue is currently the biggest drawback for me.

        Thanks

        Comment


        • #19
          Originally posted by ajhernan View Post
          Hello John,

          I have the same problem with PHP 5.4.20, could you tell me when scriptcase think to resolve this bug. I'm right in the implementation phase of a project and this issue is currently the biggest drawback for me.

          Thanks
          Some Databases have a configuration to List (or not) all databases. That may be what is causing the issue.

          regards,
          Bernhard Bernsmann

          Comment


          • #20
            Originally posted by John L. Santos View Post
            Hello Mr. Igor,

            This problem occurs because the version of PHP 5.5 and not the version of MySQL
            This is just a warning message, but I do not know why Scriptcase is not listing databases.
            We are checking this problem.
            Any news about this problem?

            Comment


            • #21
              Originally posted by John L. Santos View Post
              Hello Mr. Igor,

              This problem occurs because the version of PHP 5.5 and not the version of MySQL
              This is just a warning message, but I do not know why Scriptcase is not listing databases.
              We are checking this problem.




              You can use PHP version 5.4 without problems.
              Any news about this problem?

              Comment


              • #22
                I come across this problem, as far as im aware it's because MySQL extension is deprecated in PHP 5.5.x. You will have to update your database to MySQLi or a run your app on a server running PHP 5.4.x or lower. This is as much as i know and i don't think it's a problem with Scriptcase.

                Comment


                • #23
                  I am having this issue also, but using PHP 5.4.
                  Any help would be appreciated as this is stopping me from installing on this server.

                  Comment


                  • #24
                    Hi everyone,
                    Same problem with me, the databases are accessible if keep the same name as development environment, the only thing is that i can't select a database, the combobox is empty...

                    (PHP 5.5)

                    Comment


                    • #25
                      Hello guys,

                      Could the issue be related to MySQL's show database on your prod environment? http://dev.mysql.com/doc/refman/4.1/...databases.html

                      regards,
                      Bernhard Bernsmann

                      Comment


                      • #26
                        Has this been resolved? It looks like the initial post was 6 months ago. Downgrading PHP to a lower version is not an option, nor an acceptable solution.
                        Even if in the interim you provide a way to manually edit the configuration file, if possible, that would suffice. I am unable to use this software as advertised because of this flaw.
                        Thanks.

                        Comment


                        • #27
                          I concur with lanrobo - this is causing me a huge problem as downgrading is also just not an option. Does or will SC 8 resolve this? If so when is it expected to be made available?

                          bartho - "mysqlshow" from the command line shows the databases fine whether as root or a different user
                          Last edited by adz1111; 06-11-2014, 11:38 AM.

                          Comment


                          • #28
                            Hello,
                            I have the same problem. I can't choose a database.

                            My environment is:
                            ubuntu 14.04.1
                            Zend 3.3
                            PHP 5.4.20
                            Apache/2.4.6
                            MySQL Server version: 5.5.38-0

                            ScriptCase Devel: 8.0.000
                            ScriptCase Prod: 7.1.010

                            Can someone choose the database in the scriptcase production environment with PHP 5.4 or higher?

                            Pleased, it's very urgent!!
                            Attached Files
                            Last edited by ajhernan; 07-31-2014, 08:50 PM.

                            Comment


                            • #29
                              Hello again:

                              In may previous post I said that my PHP version was 5.4.20, but it was a mistake. these was the result of may scriptcase diagnosis. My PHP version is 5.5.9 and as I red I need PHP 5.4 to work fine in production environment.

                              The problem is that ubuntu 14.04 LTS comes with PHP 5.5 and it's not easy to downgrade PHP 5.4. Then previous ubuntu 12.02 LTS comes with PHP 5.3.10, but you can upgrade to php 5.4.20 easily. Therefore, I think that while ScriptCase not support php 5.5 is recommended to use ubuntu 12.02 winth PHP 5.4.20

                              The question is whether to have the php version 5.5 instead of 5.4 is the reason that no databases appear in the drop down list and when ScriptCase will support php 5.5?

                              Comment


                              • #30
                                Originally posted by ajhernan View Post
                                Hello again:

                                In may previous post I said that my PHP version was 5.4.20, but it was a mistake. these was the result of may scriptcase diagnosis. My PHP version is 5.5.9 and as I red I need PHP 5.4 to work fine in production environment.

                                The problem is that ubuntu 14.04 LTS comes with PHP 5.5 and it's not easy to downgrade PHP 5.4. Then previous ubuntu 12.02 LTS comes with PHP 5.3.10, but you can upgrade to php 5.4.20 easily. Therefore, I think that while ScriptCase not support php 5.5 is recommended to use ubuntu 12.02 winth PHP 5.4.20

                                The question is whether to have the php version 5.5 instead of 5.4 is the reason that no databases appear in the drop down list and when ScriptCase will support php 5.5?
                                You can override PHP version with .htaccess AFAIR

                                If not, you can use vhosts using a different PHP version too. PHP 5.4 and 5.5 and 4, can live in the same enviroment, you don't need to downgrade all system.
                                /Giuseppe

                                Professional Scriptcase Services
                                Some Customers opinions

                                Comment

                                Working...
                                X