Announcement

Collapse
No announcement yet.

Presentation and problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Presentation and problem

    Hello
    My name is Daniel Luna and greetings from Argentina.
    Buy the product a week ago and today I did a little project for a grid and menu.
    By deploying the final draft within a subfolder on a wamp server gives me the following error when running:
    Fatal error: Class 'nm_data' not found in D:\programas\paginas\hospital\pagina\2014\menu\ind ex.php on line 236
    Call Stack
    # Time Memory Function Location
    1 0.0137 818104 {main}( ) ..\index.php:0
    2 0.0356 862096 menu_class->menu_menu( ) ..\index.php:989

    The diagnosis gives me an error in zend library, I have to install this framework to work? or other problem, the attached file for more information diagnosis.
    Thanks and regards.
    Daniel Luna
    sorry for my English (google translate)
    Attached Files

  • #2
    When you deploy your application you don't need to setup anything else then your database and php. So it should run without problems. Did you deploy fully with libs etc? I would retry to deploy as something might went wrong. Are you running on linux or windows?
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Thanks for the reply Albert.
      This running under windows with wamp server, including all libraries. I create a folder but apparently _lib then not found, generate 6 times, and still giving error. so you see that was an alias in wamp, it seems a matter of routes.
      I will keep trying, seemed weird because I do not see anyone in the forum or on my google searches with the same problem.
      If you think of anything let me know.
      regards.

      Comment


      • #4
        temporary solution

        Achieve a solution, apparently the problem with wamp server aliases.
        Copying files to the root of wamp generated work well.
        I will keep looking for the solution to work within the alias.
        Thanks for taking your time.
        regards

        Comment


        • #5
          Originally posted by aluna2 View Post
          Achieve a solution, apparently the problem with wamp server aliases.
          Copying files to the root of wamp generated work well.
          I will keep looking for the solution to work within the alias.
          Thanks for taking your time.
          regards
          I deploy my applications under a subdirectory of the webroot. I don't have issues with wamp, xamp nor uniform. Could you explain what your are trying to do?
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #6
            My folder structure is as follows:
            D :
            programs
            -Name_Client
            --Documentation
            --webpage
            --Mobile
            --desktop_programs
            --Original_Images
            --Export database
            -Other_Client

            D : MYSQL
            All Databases

            c: \ WAMP
            wwww ( Empty )

            and I think the alias from wamp pointing to d: \ programs \ client \ webpage, then acedo by htt : \ \ localhost \ alias_name \ this works with all of my client, but until now always wrote the php code and javascript by hand without using generators. Using relative paths always and have never had problems , now that I know that ScriptCase works this way is that there will be problems in the distribution because clients hosted locally or on a webserver .
            One was my doubt it took to deploy some other library, in addition to the natural suspicion that causes me the fact that you do not use code written manually , but at first glance the benefits of using a generator in saving time and learn more the tool will surely disappear that initial distrust.
            Thank you very much for your interest in the problems of others, their see much activity in this forum.
            regards

            Comment

            Working...
            X