Announcement

Collapse
No announcement yet.

Friendly URL names and application names confusion

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Friendly URL names and application names confusion

    After a week of trying to deploy an application to a client's remote server, I may be starting to sound terse, so apologies in advance.

    The latest issue was that the project, which tested OK in the development environment, on a VM that I maintain for testing, and on my web-server, was creating 404 errors on the client's server when couple of applications tried to call other applications.

    I eventually worked out that the problem was wrong application directory names& URL calls were created when "Friendly URL names" were in use. For example, the application in the development system is "ctrl_showme". The friendly URL is "Show_me".

    On deployment the "ctrl_showme" application directory is created as "Show_me", but the call from other application is to "ctrl_showme", resulting in a 404. No amount of code regeneration or re-deployment would fix it. In the end I had to take out the friendly URLs or manually rename directories after deployment

    So, is this deployment behaviour by design, a bug, or simply intended to drive us crazy?
    The GuiGuy
    ... from Down Under

  • #2
    Hmm, I was just about to start using Friendly URL feature. Has this been fixed ?

    ARTHUR

    Comment


    • #3
      Originally posted by aka View Post
      Hmm, I was just about to start using Friendly URL feature. Has this been fixed ?

      ARTHUR
      Arthur,Friendly URLS seem to work only when used in the initial application design and save phase. To explain, if I create and and save an application WITHOUT a friendly URL and then, after the initial save, introduce a friendly URL the situation I have described above occurs.

      I'd post it as bug report, but based on past experience there seems little point...
      The GuiGuy
      ... from Down Under

      Comment

      Working...
      X