Announcement

Collapse
No announcement yet.

mysql extension is deprecated and will be removed ... : use mysqli or PDO instead

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql extension is deprecated and will be removed ... : use mysqli or PDO instead

    Screenshot from 2016-05-29 12-53-53.png


    Same old problem as described after several years posted. I can't find a clear solution on forums.

    We get:

    Connection Success after installing deployment on production machine but:

    Connection Error

    mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead

    When trying to select Database Name

    My only guess is both development and production machine must run same PHP version.
    Any ideas?

    Production Env:
    buntu 15.10
    XAMPP for Linux 5.6.21
    PHP Version 5.6.21
    Development Env:
    Scriptcase V6
    CentOS shared server
    PHP Version 5.3.29
    Thank you in advance.
    Last edited by electrocoder; 05-29-2016, 03:41 PM.

  • #2
    If you dont move from from PHP version is ok. MySQL extension is marked deprecated in different PHP versions, and removed on PHP7
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      There's a good (security) reason for that. Therefore I recommend using pdo.
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development
      www.scriptcase.eu / www.scriptcase.nl

      Comment

      Working...
      X