Announcement

Collapse
No announcement yet.

Problem while exporting report in pdf or excel format on IIS hosted server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem while exporting report in pdf or excel format on IIS hosted server

    we are getting problem while exporting report in pdf, word, excel or any other. It is working fine at my local using Apache server but when we hosted it on IIS server its not working. Can any one suggest how can we solve this problem

  • #2
    I got the same problem ! The same for my experience untill now. It's a very old problem noticed more that one YEAR and an HALF ago !!
    Is it possible that this problem is still present and overall not fixed ?

    Comment


    • #3
      My suggestion: create a seperate user under IIS with more rights, namely the right to write to the directory where the pdf is created. Then set your IIS service so that that user is the one that that runs the service, so not the default service user. Then also you have to set the directory rights properly so that the user you created has all the proper rights to the dirs. After that just restart the IIS service (use the IIS manager for that) and you should be done... In any case, check the logs for details on what went wrong if it doesnt work.
      This problem is NOT a scriptcase problem but an IIS security issue imho. It isnt even a bug or so, it is how IIS works.

      Comment


      • #4
        Hi rr,
        my projects are mainly hosted on a server where I can't modify what I like. This hosting company is one of biggest here (www.aruba.it).
        This is the link to php info but I'm not able to understand if your suggestions to fix export problems are valid or not here. I can modify rights only to 777 of some directories but it do not works the same.
        http://lnx.kfive.it/php_info.php

        Comment


        • #5
          That is an apache server so there should be no IIS problem. I guess I am misunderstanding you.

          Comment


          • #6
            Ok, but the problem is that it do not work.

            Comment


            • #7
              I still suspect it is an apache issue, are your .htaccess files properly set? You should be able to alter those. Can you activate full logging on your server and check the logfiles?
              Did you set the error_log parameter and check the log file? There should be more info there why it goes wrong...

              I see from your settings that you do not have the error log file set, I suggest you activate it first and check the result.

              Comment


              • #8
                Unfortunately not. I've only visibility on all project's folders and files and on mysql db tables.
                It's quite a bad situation. ;-(

                Comment


                • #9
                  Originally posted by giovannino View Post
                  Unfortunately not. I've only visibility on all project's folders and files and on mysql db tables.
                  It's quite a bad situation. ;-(
                  Perhaps I overlooked, but is this a SC 6 or SC 7 issue? Point is that in SC 6 it's highly likely that it will not function as SC6 is relying on the java runtime (JRE). This JRE is almost nowhere supported. But if it's SC7 then it should work, at least under apache. I don't work with IIS so can't tell for that, my Windows servers all run Apache ;-)
                  Albert Drent
                  aducom software netherlands
                  scriptcase partner, reseller, support and (turn-key) development
                  www.scriptcase.eu / www.scriptcase.nl

                  Comment


                  • #10
                    My projects are all on SC 7.1.09. I read about the fixing of problem on changelog and I was very happy about that becouse it was almost two year that I'm fighting with this problem. Unfortunately something blocking is still present and anybody has still a solution. It's obvious that it comes out in hosting services not in private server.

                    Comment


                    • #11
                      This is the url I see with blank page after trying to visualize the PDF doc
                      http://lnx.kfive.it/c4tm/_lib/tmp/sc...lot_search.pdf
                      and attached the LOG zip of all files produced under _lib/temp of server folder.
                      Attached Files

                      Comment


                      • #12
                        Ok, let's go on. Does your application have write rights on the ..._lib/tmp folder? If it has 644 (which is likely) then this needs to change. Second: is there a .htaccess on this folder and if so, what's in it. Third, do you have access to the apache and php error and access log? This can deliver valuable information...
                        Albert Drent
                        aducom software netherlands
                        scriptcase partner, reseller, support and (turn-key) development
                        www.scriptcase.eu / www.scriptcase.nl

                        Comment


                        • #13
                          I can only change the rights of folder to 777 . All other stuff is owned by hosting service.
                          I've asked to them if they can switch on log for a while and send me back the log file.

                          Comment


                          • #14
                            This is result after setting 777 to tmp folder and subdir.
                            It switched it automatically to 755 and I think it's good the same.
                            All files just produced again in this moment by SC remain on 0644. I think the problem is under one of the other point you listed.
                            Attached Files

                            Comment


                            • #15
                              755 might not be a good thing. Issue is that only the owner has write rights, not the group or public. Depending on the apache installation it might be that apache is the owner of the files. In that case you cannot write to the directory. I guess it's a rights issue. It's also strange that 777 is automatically switched to 755. I think you need to ask your provider to allow to set it to 777. Or 666, you don't need execute rights in this directory.
                              Albert Drent
                              aducom software netherlands
                              scriptcase partner, reseller, support and (turn-key) development
                              www.scriptcase.eu / www.scriptcase.nl

                              Comment

                              Working...
                              X