No announcement yet.

Can't get PDF Header to display

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get PDF Header to display

    I have a PDF report that is working great with one exception - I cannot get a header to display.
    I am trying to put some text in the indicated header area and have been trying things for two days now and dont know what it takes to get something to appear.

    The report is a multi-record report, and this part is fine. I have a background image that I use and that is a guide for positioning the cell data.

    Please see the attachments. If anyone can tell me how to get a header to show up, I would be grateful.

    Here is my PDF output. I want something in the red circled area

    I tried adding some code to the layout logic. It does nothing.

    I edited the generated file and change the setPrintHeader setting to True but it doesnt help.


    Here is the main settings page for my report - nothing even mentioned anywhere about a header.
    Attached Files

  • #2
    Does anyone from SC monitor these forums? Pretty useless otherwise it seems. There are a lot of unanswered questions in here.


    • #3
      I did figure this out if anyone is interested.
      I had to create a new file that creates a class which extends the TCPDF class and change the generated code from scriptcase to include my extended class file instead of the tcpdf.php file.
      Then I changed the setPrintHeader and setPrintFooter to (true) instead of (false).
      Now I have a header and a footer on my PDF.