Announcement

Collapse
No announcement yet.

Convert applications from SC 8.1 to SC 9.1 database connection is stuck issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Convert applications from SC 8.1 to SC 9.1 database connection is stuck issues

    Used the SC 9.1 conversion program to move a series of applications I still had in 8.1 over. I have several different database connections that I have associated with my sc applications, one for each different client. This is necessary for me to do. For example, conn_ehfood_dewitt and conn_ehfood_piatt are two different connections that are associated with one of my applications. I converted the applications while they were connected to conn_ehfood_dewitt. After I generated the apps and deployed them to my dewitt folder I used the quick change editor to change the connection and field connections to conn_ehfood_piatt. I generated the apps with the new connection and found that when trying to deploy, many of the grids were now trying to use both the conn_ehfood_dewitt and conn_ehfood_piatt. I went through each grid individually and in the SQL area they show the new connection. I looked at the field connections for anything requiring an sql statement and they all show the new connection. I manually opened the php file and see both connections in there instead of just the one. I've tried changing the connections again, editing the connections manually, deleting the connection that seems to be stuck and nothing is making it go away. I even went so far as to delete the generated file folder and generate a new one. It's stuck. There is no security in use and there is no log associated with the applications either so that's not causing it to stick. I don't want to have to rebuild all of these applications from scratch. Any ideas?
Working...
X