Announcement

Collapse
No announcement yet.

2 Ajax "on change" processes on same form not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2 Ajax "on change" processes on same form not working

    I have a form application that has 3 select options. They are Venue, Event, Position. The idea is to filter down to the position for a given venue and event. The database is setup that a position (PositionID) contains a VenueID and EventID. And furthermore, an EventID contains a VenueID. So the first select (Venue) works great. The ajax is working correctly to populate the second select (Event) where VenueID = '{VenueID}'. However, because the Event select list needs also call an AJax on change event to filter the 3rd select (Position based on the EventID, the processing just goes into a loop. Can you not use the Ajax event on more than 1 select on a form application? Is there a better way to do this?

    Thanks!

  • #2
    Re: 2 Ajax "on change" processes on same form not working

    Hello,

    You can have 2 ajax processing, no worries there. Make sure that there is no problem with your logic, try testing just the first ajax processing and then, just the second one to see if it works.

    If that doesn't solve the issue, please contact our support. Our chat is active on workdays from 8:00am to 6:00pm, and our ticket system is always available.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      hi, i need revive this topic, i have 2 ajax processing to re-load on change, first is working fine,, second is making the ajax processing message keep looping infinite.. i tried to make this process alone and disabled the first one, same thing, it is something in this fields only... even if it is simple like {select1} has a list of 4 items.. and {select2} has 5 items.. the process is on select1 supposed to reset {select2} and that is happening actually select2 is going to the first value as expected but the ajax processing message up there is still appearing and looping without stop until if the form is saved! any idea to know why this is happening!?

      Comment

      Working...
      X