Announcement

Collapse
No announcement yet.

Troubles with Tabs linking to Form

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Troubles with Tabs linking to Form

    I have a dataset that I display in a multiple record form. The data set has 3 different types of info.
    So I've created a tabs application so my user can just click the tab to view each subset of data.

    I want to use the same form and pass a parameter to specify which subset to display.
    (WHERE: subset = [glob_subset])

    The form handles this fine but the tabs app is failing.
    In each tab, I set the Link between applications with the global to a fixed value.
    tab1 [glob_subset] = 1; tab2 has [glob_subset] = 2; tab3 has [glob_subset] = 3

    However, when the form is linked to the global value is always 3 ... the last value assigned.
    So each tab then displays the subset 3.

    I've been trying to work around this for hours.
    I'm getting close to creating 3 versions of the form with the subset hard-coded. Ick!

    Any ideas or am I missing something obvious.

    You guys are great.

    Thanks in advance for your help! tunester7

  • #2
    Didn't tried but, did you checked Reload Frame in App Configuration of your tabs app?
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      I just tried setting the frame to reload. That didn't help. The global still ends up with the value set by the last tab. thanks for trying

      Comment

      Working...
      X