Announcement

Collapse
No announcement yet.

Informix Database Connect returning blank fields

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Informix Database Connect returning blank fields

    I have setup a Linux, Apahce, PHP, Infomrix server and have scriptcase installed. I am able to make an Informix connection and it tests out ok. If I try to create a form, the screens appear to show the correct number of lines, but the data is all blank (I expect 13 rows, I see 13 row on the screen just no data). If I run the same sql in the SQL Builder, I am able to see the data as expected. Any ideas? I have tried form, grid, PDF Report and they all do the same thing.

  • #2
    Re: Informix Database Connect returning blank fields

    What datatype are your fields in the database?
    Alan

    Comment


    • #3
      Re: Informix Database Connect returning blank fields

      All different types are acting the same way. Some chars, some varchars, some numeric.

      Comment


      • #4
        Re: Informix Database Connect returning blank fields

        I have done some further debugging and I have found that the data is there however, in the class file that is generated by scriptcase it is referring to rs_grid->fields[0], [1], etc and php is not recognizing those indexes in the array. If I change the code to be rs_grid->fields[id], [c_name] (the database field names) the data shows as expected.

        Also, I have noticed that if I add an echo of the $this->rs_grid that the variable goes away. A second echo of $this->rs_grid shows just the field names:

        example:
        Code:
        echo "aaaa".$this->rs_grid."bbbbbb<br>";
        echo "xxxxx".$this->rs_grid."yyyyyb<br>";
        gives:
        aaaaid,c_name,addr1,addr2,addr3,addr4,billing data1, data2,,....bbbbbb
        xxxxxid,c_name,addr1,addr2,addr3,addr4,billing yyyyyb

        Comment

        Working...
        X