Announcement

Collapse
No announcement yet.

Oracle connection issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oracle connection issues

    I am new to SC currently using SC6. This is my first oracle application with it. I have made a couple MySQL and SQLite without problem. Additionally I have written other PHP and PERL pages by hand but not with SC that are running on this server and connecting to this database. So I know the server can communicate with the oracle DB without issues. I connect and build from the software just fine. The transfer to my server is problem free, I have the instant client installed and the tnsnames if filled out for the DB I am connecting to. When I log into the _lib interface and setup the database connection it tests good with the green check box. But when I goto the application url I get the following error ->

    Fatal error: Class 'ADORecordSet_ext_oci805' not found in /fac-nas/Shared/WebSite/dev/private/keyshop/_lib/prod/third/adodb/adodb.inc.php on line 1129

    Any ideas? As this is an error in the scriptcase lib files I am a little lost on how I should trouble shoot it.

    Thanks
    Jason

  • #2
    Re: Oracle connection issues

    Hello,

    Even though your server is already configured to accept Oracle Connections, please follow our Web Help in order to configure Oracle properly to work with SC.

    regards,
    Bernhard Bernsmann

    Comment


    • #3
      Re: Oracle connection issues

      Bernard,

      Thanks for the reply. Sorry I forgot to mention that I had already followed the guide, and was providing additional evidence that it was not a system configuration problem. The only thing that has an issue connecting are things written in SC. Is there some way to add logging to the application, its a simple 1 grid app to show a single table with search capabilities, nothing complicated, but when monitoring the server there is no connection attempted. Again from my web server I am able to manual connection (sqlplus), other PHP websites (proving the php.ini is good), and the test connection in project/_lib/ interface all work without error connecting to this database. Additionally the php info page indicates that oci8 is enabled.

      To double check I have followed the connection setup guide again. Instant client installed, php configured and confirmed, and connection setup in the _lib/ interface. The guide indicates that if the connection tests ok then it is not a connection issue. This is not the case, the connection tests just fine. But the application itself still just has an class not found error looking for ADORecordSet_ext_oci805. The connection is to an oracle 11g database if that matters.

      Anyways, what is the suggested way to trouble shoot a problem such as this? There is no additional information in the apache logs to indicate what the source of the problem is. Any suggestions would be appreciated.

      Thanks
      Jason

      Comment


      • #4
        Re: Oracle connection issues

        Check my other post, I had an oracle issue as well tho with the full client. I think my solution ought to work with your oracle client as well.
        And I did not use the dao connection but the connection called 'Oracle 8.0.5 or higher' I think that for dao useage it the same issue may occur..

        Comment


        • #5
          Re: Oracle connection issues

          Hello,

          If rr's post doesn't suit your problem, please contact our support and they will be able to diagnose why you aren't able to connect properly.

          Here is his post. I haven't tested it yet, so follow at your own risk.

          regards,
          Bernhard Bernsmann

          Comment

          Working...
          X