Announcement

Collapse
No announcement yet.

More Macro Woes: Why doesn't this work?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • More Macro Woes: Why doesn't this work?

    sc_link(IndexNo, form_registerdata.php, ID = {IndexNo} , "Register Data Detail", "_self");
    IndexNo is a valid field in the grid form calling form_registerdata.php

    ID is the primary key field in form_registerdata.php.

    form_registerdata.php always opens on the first record in the database, so the parameters "ID = {IndexNo}" seem to be ignored <sigh>

    This is the code from the link:
    javascript:nm_gp_submit5('/scriptcase/app/ffphp/form_registerdata/form_registerdata.php',%20'/scriptcase/app/ffphp/grid_view_registerdata/grid_view_registerdata.php',%20'ID?#?3552?@?',%20' _self',%20'',%20'440',%20'630')
    The GuiGuy
    ... from Down Under

  • #2
    Re: More Macro Woes: Why doesn't this work?

    Do you have the Primary Key set in your form?

    If you echo {indexno} in your form, does it give you the correct number, or zero?

    Regards,
    Scott.

    Comment


    • #3
      Re: More Macro Woes: Why doesn't this work?

      [quote author=ScottMartin link=topic=4046.msg9467#msg9467 date=1300123641]
      Do you have the Primary Key set in your form?[/quote]

      Yes. It's on the ID field which is clearly visible on the form being called.

      If you echo {indexno} in your form, does it give you the correct number, or zero?
      Yes. IN any case, the problem occurs in applications, that have been working OK for months, after regenerating code in the latest version of SC.

      Thanks

      The GuiGuy
      ... from Down Under

      Comment

      Working...
      X