No announcement yet.

Deployment/ Production problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Deployment/ Production problem

    Hi All,
    I am trying to re-deploy an application I wrote some time ago under SC5.2. The client's server was attacked and was rebuilt. I am using the same deployment file that was originally and successfully used.

    I expected the connection manager to pop up but instead I am getting

    You don't have permission to access appdir/_lib/prod/lib/php/nm_ini_manager2.php on this server
    It's on linux/ apache2 and php 5.3.8. It is exactly the same environment the application was previously running on. I am confident it's not a permission error because even when I set everything to chmod 777 I get the same "permission" error, which seems really weird.

    Is the environment wrong? Is there a way to overcome this?


    The GuiGuy
    ... from Down Under

  • #2
    Re: Deployment/ Production problem

    Sounds like what it is saying; a permission problem.

    PHP files set as 777 probably will not run. See if the host can set up php to run as CGI this will avoid permission issues with PHP. Now that my server is setup this way I will not go back. Under this method, folders are 755 and files are 644. Works for me.
    Latest version of Scriptcase updated regularly. Hosted on my own Cpanel server running php 5.4x and Centos. Use latest version of Firefox for development browser.


    • #3
      Re: Deployment/ Production problem

      php files only need read access. So why 777 when PHP is running as a module? IMHO there are differences running as cgi or as module but that refers to the owner of the files when you create a subdir in your php i.e. But AFAIK the rights should never be 777. Only upon installation time sometimes.
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development /