Announcement

Collapse
No announcement yet.

PHP must have mbsting extension enabled

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP must have mbsting extension enabled

    I created a simple on record form for one MySQL tables as a test for ScriptCase. The form worked locally, but when I pushed it out to my website on GoDaddy, I got the following error.

    "The php must have the mbsting extension enabled. Please contact the tecnical support"

    Does anyone know if this is something I can take care of or is it a GoDaddy issue? Is there some setting I need to add/change?

    Thank you

    Jeff

  • #2
    Re: PHP must have mbsting extension enabled

    You must enable mbstring extension in php.ini

    Comment


    • #3
      Re: PHP must have mbsting extension enabled

      [quote author=vitorjamil link=topic=1034.msg2933#msg2933 date=1250279253]
      You must enable mbstring extension in php.ini
      [/quote]

      I have mbstring extenstion enable in php.ini and I am still getting this error

      The php must have the mbsting extension enabled. Please contact the tecnical support

      Please advise
      Reginald Bailly

      Comment


      • #4
        Re: PHP must have mbsting extension enabled

        Find out what the are are using for the server (Windows/Linux). In most cases, you have to specify mbstring during installation. Changing the php.INI is not enough. Contact ISP.

        Regards,
        Scott.

        Comment


        • #5
          Re: PHP must have mbsting extension enabled

          [quote author=ScottMartin link=topic=1034.msg4513#msg4513 date=1271900826]
          Find out what the are are using for the server (Windows/Linux). In most cases, you have to specify mbstring during installation. Changing the php.INI is not enough. Contact ISP.

          Regards,
          Scott.
          [/quote]

          I am using a Linux Server - mbstring is enable - I already contacted my ISP and they confirm that mbstring is enabled

          on my local computer - it works fine - but when I upload to my server - I get error message just before the login screen
          Reginald Bailly

          Comment


          • #6
            Re: PHP must have mbsting extension enabled

            I still believe this is a ISP issue.

            -Has the Server been restarted since you changed the setting in PHP? it will not adhere until.

            -Is this a shared, virtual or dedicated account?
            -What PHP version is used?
            -Which charset are you using ... UTF-8?

            Regards,
            Scott.

            Comment


            • #7
              Re: PHP must have mbsting extension enabled

              Could you attach your diagnosis file to we analyze it?

              Comment


              • #8
                Re: PHP must have mbsting extension enabled

                [quote author=vitorjamil link=topic=1034.msg4543#msg4543 date=1272302191]
                Could you attach your diagnosis file to we analyze it?
                [/quote]

                Which diagnosis file you are talking about?
                My php.ini file or ?
                Reginald Bailly

                Comment


                • #9
                  Re: PHP must have mbsting extension enabled

                  There is a file called diagnose.php that is included that you can run and it will spit out data. It is in the root of your app.

                  Regards,
                  Scott.

                  Comment


                  • #10
                    Re: PHP must have mbsting extension enabled

                    [quote author=vitorjamil link=topic=1034.msg4543#msg4543 date=1272302191]
                    Could you attach your diagnosis file to we analyze it?
                    [/quote]

                    I managed to solved the mbstring problem - I no longer getting this message
                    - after I enter my password in the production environment section
                    - I get the following error message

                    Erro ao criar arquivo temporário.
                    Reginald Bailly

                    Comment


                    • #11
                      Re: PHP must have mbsting extension enabled

                      means:
                      Error creating temporary file.

                      You have to change your rights for dir/files where you installed your project.

                      Regards,
                      Scott.

                      Comment


                      • #12
                        Re: PHP must have mbsting extension enabled

                        Check the following link.

                        http://scriptcase.net/phpgenerator/b...p?id_topico=35

                        Comment


                        • #13
                          Re: PHP must have mbsting extension enabled

                          [quote author=vitorjamil link=topic=1034.msg4589#msg4589 date=1272564268]
                          Check the following link.

                          http://scriptcase.net/phpgenerator/b...p?id_topico=35
                          [/quote]

                          Ok everything worked fine - I am having problems with the database name - the one on the server is not the same as that i was working in local drive

                          which means - I need more planning
                          Reginald Bailly

                          Comment


                          • #14
                            Re: PHP must have mbsting extension enabled

                            When you run the deploy wizard, you can click on the DB connection icon and specify your DB name/settings.

                            Regards,
                            Scott.

                            Comment


                            • #15
                              Re: PHP must have mbsting extension enabled

                              [quote author=ScottMartin link=topic=1034.msg4601#msg4601 date=1272633311]
                              When you run the deploy wizard, you can click on the DB connection icon and specify your DB name/settings.

                              Regards,
                              Scott.
                              [/quote]

                              when I reached that level, I had 3 different database waiting to be installed - the name chosen were too long

                              I have to go back and changed the database selection from each form and each grid of the application

                              I wonder if there is command to changes the database name in all application at once?
                              Reginald Bailly

                              Comment

                              Working...
                              X