Announcement

Collapse
No announcement yet.

SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)

    I try to use scriptcase on cherokee, this my first experience with sc.
    after extract to directory and add zendguard.so to php.ini,
    i got this message when try http://localhost/scriptcase with google-chrome browser
    ---start---messg
    Server error
    The website encountered an error while retrieving http://localhost/scriptcase/index.php. It may be down for maintenance or configured incorrectly.

    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.
    ---end---messg

    when using firefox, i got white blank view.
    anyone can help with this problem ? pleasee..
    sorry if my english is bad...
    other info...

    drwxrwxrwx /var/www/scriptcase

    /etc/php5/cgi/php.ini (cherokee use fastcgi)

    ---start----part of php.ini
    ;;;;;;;;;;;;;;;;;;;;
    ; Language Options ;
    ;;;;;;;;;;;;;;;;;;;;

    ; Enable the PHP scripting language engine under Apache.
    ; http://php.net/engine
    engine = On

    zend_extension="/lib/ZendGuardLoader.so"

    ; This directive determines whether or not PHP will recognize code between
    ---end-----part of php.ini



  • #2
    Re: SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)

    I suspect it is a PHP version issue. SC cannot run on PHP5.3 or later. Make sure that you're using PHP5.2

    As an side I see PHP is now at version 5.3.5. It his high time the SC team made a statement about what, if anything, it will do about this. I for one am not keen to be using 5.2 for as the rest of the world moves on.
    The GuiGuy
    ... from Down Under

    Comment


    • #3
      Re: SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)

      ouch.. ! you're right....
      sigh.. I can't try it...
      when it will be running on php5.3 ?

      big thx to you..

      $> php --version
      PHP 5.3.3-1ubuntu9.4 with Suhosin-Patch (cli) (built: Apr 27 2011 05:24:59)
      Copyright (c) 1997-2009 The PHP Group
      Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
      with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

      Comment


      • #4
        Re: SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)

        [quote author=ekopranoto link=topic=4323.msg10180#msg10180 date=1304316645]
        when it will be running on php5.3 ?
        [/quote]

        I don't think it ever will in its current form or under its current licence, which makes SC a bit of a risk in the long term.

        You can downgrade your ubuntu install to PHP5.2. Either google or try this:
        http://2bits.com/drupal-planet/vario...ucid-lynx.html
        http://randyfay.com/node/63

        Good luck....

        The GuiGuy
        ... from Down Under

        Comment


        • #5
          Re: SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)

          No comment.

          Comment


          • #6
            Re: SC on Cherokee WebServer Linux Mint 10 (Ubuntu 10.10)


            The Scriptcase doesnt work under PHP 5.3, you must install 5.2.xx you can try to mount your environment with Zend Server PHP 5.2 then download the .zip version or tar and try to install.

            Or you can install the Apache, Zend Optimizer and PHP by yourself.

            See this link to know how to do this: http://www.scriptcase.net/phpgenerat...?id_topico=285

            Comment

            Working...
            X