Announcement

Collapse
No announcement yet.

Im just getting question marks

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Im just getting question marks

    Hi,

    i installed lampp with php 5.2.9 which contains the zend engine v2.2.0

    Code:
    PHP 5.2.9 (cli) (built: Mar 31 2009 23:21:47)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    then i put the package scriptcase-5.0.008-en_us in the htdocs-directory.

    but all i am getting are questions marks like here http://mpz-bn.dyndns.org:8086/scriptcase/index.php

    why is that?

    thanks for your help,

    Mati

  • #2
    Re: Im just getting question marks

    You need to install Zend Optimizer:
    http://mpz-bn.dyndns.org:8086/scriptcase/diagnosis.php

    Regards,
    Scott.

    Comment


    • #3
      Re: Im just getting question marks

      Hello Scott,

      thanks, that was very helpful. i got it installed now.

      It doesnt save my licence-key i guess its because of one of the following erros from the diagnostic:

      Enviroment 2
      • [li]ZendId execute Permission [/li]
        [li]ID:[/li]

      ScriptCase Environment
      • [li]ID:[/li]
        [li]Max Apl Date:[/li]

      could you give me a hint, how to fix these errors?

      thanks a lot,

      mati

      Comment


      • #4
        Re: Im just getting question marks

        I would say that you need to clean up your 2 Zend errors, then other 2 should follow. I would google the cause of the first 2. I would say it was a permission error. use chown/chmod to update your .SO file.

        Regards,
        Scott.

        Comment


        • #5
          Re: Im just getting question marks

          Hello Scott,

          thanks for your answer.. i allready changed the permissions for the .SO but it didnt help me.

          it looks like this (ls):

          Code:
          930199 1.4M -rwxrwxrwx 1 wwwrun root 1.4M May 31 17:44 ZendOptimizer.so
          with root as owner it doesnt work either.

          thanks for your help,

          mati

          Comment


          • #6
            Re: Im just getting question marks

            That should work. Mine is:
            -rwxr-xr-x 1 root root 1745730 2009-08-19 07:29 ZendOptimizer.so

            Perhaps if you restart Apache/MySQL and or you PC?

            Are you running on 32bit? What is your distro?

            Regards,
            Scott.

            Comment


            • #7
              Re: Im just getting question marks

              This might point you in the right direction:
              http://www.mentby.com/nicosia-gaetan...ermission.html

              Regards,
              Scott.

              Comment


              • #8
                Re: Im just getting question marks

                hello scott,

                thanks for the answer.

                i restarted but doesnt work now... i am on 32bit with opensuse... i allready found the page you mentioned, but it says thats for 64 bit.

                any other ideas?

                thanks

                Comment


                • #9
                  Re: Im just getting question marks

                  I ran:
                  http://mpz-bn.dyndns.org:8086/scriptcase/info.php

                  Your Zend Entries are almost the same except in the top section, you have a 'Configure Command' entry that is polluted with lampp entries. On of them has an entry of:
                  '--enable-zend-multibyte'

                  I would try and toggle this in your PHP.ini and see if it helps. (restart apache).

                  If this does not work, then I am at a loss.

                  I will say that I do not have the entire 'Configure Command' section at all. I am sure this LAMPP stuff. I used to use XAMPP/LAMPP but got tired of all the differences when going live.

                  I have since just started to install LAMP (not to be confused with LAMPP). It mirrors what most ISP's have of using '/var/www' instead of '/opt/lampp/htdocs' and does not have all the extra baggage of LAMPP/XAMPP.

                  Regards,
                  Scott.

                  Comment


                  • #10
                    Re: Im just getting question marks

                    Also, Zend is picky on it's PHP version. Perhaps a PHP upgrade may help.

                    Regards,
                    Scott.

                    Comment

                    Working...
                    X