Announcement

Collapse
No announcement yet.

Wrong time displayed after deploy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wrong time displayed after deploy

    Hello,
    After i have deployed my application , i get the wrong time displayed -2 hours (italy).
    Can anyone help to solve this ?
    Thanks in advance to you all.
    Maurizio

    This is the message i get

    strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.

  • #2
    This is something which has to be solved in your php environment. Problem is that if it's a regular hosting you haven't got this opportunity all the time and you might need to set the timezone in your application.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Originally posted by aducom View Post
      This is something which has to be solved in your php environment. Problem is that if it's a regular hosting you haven't got this opportunity all the time and you might need to set the timezone in your application.
      Ok- I have inserted this line in my login for (on_applicationinit) date_default_timezone_set("Europe/Rome"); and for that application the time now is corret, i have about 40 applications in my project, do i have to set timezone in each application or i can set it somewhere and be valid for all project ?
      If the answer is yes, please can you tell me where and how to do it.
      Thanks for your help
      maurizio

      Comment


      • #4
        Originally posted by mc60 View Post
        Ok- I have inserted this line in my login for (on_applicationinit) date_default_timezone_set("Europe/Rome"); and for that application the time now is corret, i have about 40 applications in my project, do i have to set timezone in each application or i can set it somewhere and be valid for all project ?
        If the answer is yes, please can you tell me where and how to do it.
        Thanks for your help
        maurizio
        In your case I advise you to get into contact with your provider. The most easy way to solve this issue is in your php.ini. But if this is not possible then you have to add this to every application where you require the time.
        Albert Drent
        aducom software netherlands
        scriptcase partner, reseller, support and (turn-key) development
        www.scriptcase.eu / www.scriptcase.nl

        Comment


        • #5
          Originally posted by aducom View Post
          In your case I advise you to get into contact with your provider. The most easy way to solve this issue is in your php.ini. But if this is not possible then you have to add this to every application where you require the time.
          Solved - I have contacted my provider and quicky the setted the right time zone, now is all working fine.

          Thanks a lot Albert for your help
          Bye

          Comment


          • #6
            For future reading, you can use too .htaccess

            http://www.htaccess-guide.com/setting-server-timezone/
            /Giuseppe

            Professional Scriptcase Services
            Some Customers opinions

            Comment


            • #7
              But only for apache hosters....
              Albert Drent
              aducom software netherlands
              scriptcase partner, reseller, support and (turn-key) development
              www.scriptcase.eu / www.scriptcase.nl

              Comment

              Working...
              X