Announcement

Collapse
No announcement yet.

SFTP Folder Path Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP Folder Path Problem

    I'm using the SFTP option for deployment to a production server and no matter how I set the "SFTP Path (Full Path)", the files always go into the root directory. My SC applications are in a sub-directory "www/sc-application" so the application files and _lib directory changes go into the wrong place, every time. My workaround has been to deploy as zip files, extract on my local machine and then upload those folders/files into the SC applications directory on the production server. A bunch of extra steps.

    I have not had this issue with straight FTP within the SC deployment process. Just SFTP.

    Does this seem like a bug? Changing the path does not do anything. I even mis-typed the path once (so it should not have worked at all) but the files still went into the root folder.

    Any help would be appreciated.

    PS: I've tried deleting the scriptcase/tmp files, clearing cache and cookies (for localhost where SC is running), restarting my browser, all to no avail.

  • #2
    Do you also have that with a commandline sftp client? For example winscp. If so then the issue is that your sftp server is set wrong.

    Comment

    Working...
    X