No announcement yet.

sc_mail_send Error using 2 possible authenticators

  • Filter
  • Time
  • Show
Clear All
new posts

  • sc_mail_send Error using 2 possible authenticators

    I'm trying to send an email using the version 7 and I'm using the sample code ScriptCase, it only change ls data for email addresses and SMTP
    and I get the following error

    Fatal error: Uncaught exception 'Swift_TransportException' with message 'Failed to authenticate on SMTP server with username "" using 2 possible authenticators' in C:\Program Files (x86)\scriptcase\v7\wwwroot\scriptcase\prod\third\ swift\classes\Swift\Transport\Esmtp\ p:176 Stack trace: #0 C:\Program Files (x86)\scriptcase\v7\wwwroot\scriptcase\prod\third\ swift\classes\Swift\Transport\EsmtpTransport.php(3 07): Swift_Transport_Esmtp_AuthHandler->afterEhlo(Object(Swift_SmtpTransport)) #1 C:\Program Files (x86)\scriptcase\v7\wwwroot\scriptcase\prod\third\ swift\classes\Swift\Transport\AbstractSmtpTranspor t.php(124): Swift_Transport_EsmtpTransport->_doHeloCommand() #2 C:\Program Files (x86)\scriptcase\v7\wwwroot\scriptcase\prod\third\ swift\classes\Swift\Mailer.php(79): Swift_Transport_AbstractSmtpTransport->start() #3 C:\Program Files (x86)\scriptcase\v7\wwwroot\scriptcase\app\realkit _completo\control_15\control_15_apl.php(1832): Swift_Mailer->send(Object(Swift_Message), Array) #4 C:\Program Files in C:\Program Files (x86)\scriptcase\v7\wwwroot\scriptcase\prod\third\ swift\classes\Swift\Transport\Esmtp\ p on line 176

    the code is

    $mail_smtp_server = ''; // SMTP server name or IP address
    $mail_smtp_user = ''; // SMTP user name
    $mail_smtp_pass = 'mypwd'; // SMTP password
    $mail_from = ''; // From email
    $mail_to = ''; // To email
    $mail_subject = 'Mensaje de prueba scriptcase'; // Message subject
    $mail_message = 'Este mensaje lo envia desde realkit.'; // Message body
    $mail_format = 'T'; // Message format: (T)ext or (H)tml

    // Send email";

    Someone could tell me I'm doing wrong?

    thank you very much

  • #2
    The errormessages sais: 'Failed to authenticate on SMTP server with username ""

    .co should be .com I think. I'm using SC7 with custom email and it's working well here. So I think there must be an error somewhere in your code.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development /