Announcement

Collapse
No announcement yet.

BIG trouble.. cant import ("it is necessary that the bkp file has been consturdo..."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BIG trouble.. cant import ("it is necessary that the bkp file has been consturdo..."

    okok, thats a big one now

    using SC 6.

    1. my server is at home. i am at work at least for the next two weeks. 550 km.

    2. i work on a very big project. last backup (here at home, downloaded) was 20th oct, now is 7th nov. backups from yesterdy dont work (see below)

    3. i do have the "auto-save"-value "on".

    4 some weeks ago i did the following: in one form-app, i changed position of a field from shown to not shown. without clicking somewhere else, i did a sh**:

    5 i did click IN THE FIEL-EDIT from SC-menu of exactly that field, which i just "removed" from the form within the "position"-area. after this, scriptcase

    6. tried to a) save my postion-change with updating sc-field-menu (in which this field now must be deleted) and b) showing exactly this fiel-option-setting (which, of course, would not longer be availible)

    7 scriptcase crashed:

    8 in that app inside scriptcase, nothing was still shown. ALL menu on the left was away: no fields, no sql-options, no events, no ajax-events, no nothing. only the headings were alive ("programming", "links"...) but no menu-entries. also i wasnt able to run the app (field is grey) nor to see source-code or anything. closing "tab" inside sc worked.

    9. no change when i re-booted my system, restarted SC, reloaded apps and so on.

    10 ok. all other apps were there and ok. so i decided to continue working on that and thought "ok, this one form app i will have to re-build from the scratch"... sometome...

    11. noticing: everything on that server became more and more slower.

    12 noticing: when i select something like "generate code of all apps" i got fail-messages with the broken form-app. but i didnt delete the app because i thougt "maybe i can resk it some day"

    13 so yesterday i made a last backup - file and downloaded it. after trying to re-import it into scriptcase on my home-server i got a error

    14 tried to delete form app. error.

    15 tried to load form-app. worked - but as i told you: no fields, no sql, no settings... BUT

    16 "run app" suddenly is visible. and... and... i tried to do. clicking "run", sc tells my "generating code..." and -

    17 nothing. stand still. after 2 hours i closed the firefox and tried to start new sc-login. but SC wasnt longer reachable

    18 the server is "on" (i can see on my teamviewer) but not reachable.

    19 cant reach anything

    20 now i had this backup-file with the not-working app i exported some hours bevore server crashed. so

    21 i installed SC local on my laptop

    22 i made a new serial number from login-menu on scriptcase-net

    23 i started up and - bang. when i try to import my backup file i got
    "
    To make importaa the project, it is necessary that the backup file has been consturdo via the File menu,
    click Export Project and the same verse of ScripCase destination.
    "

    H E L P
    what can i do?
    this is a VERY important project and very big

    i tried to delete the error-form-app from the zip-file, but this didnt work. i took a look in some of the zip-file-files ("publicacao.bkp", "usuarios.bkp" and so on) and of course there is the name of the wrong app still.
    of course i made a copy, i still have original backup-zip.

    so my questions:
    what can i do?
    is there a way to delete the broken app fromin the backup-zip? which date must be deleted?
    #for example in the "usuarios.bkp " the lists look like this:

    "
    {s:5:"group";s:17:"kundenverwaltung1";s:4:"code";s :11:"grid_kunden";}i:5;a:2:{s:5:"group";s:17:"kund enverwaltung1";s:4:"code";s:11:"form_status";}i:28 ;a:2:{s:5:"group";s:17:"kundenverwaltung1";s:4:"co de";s:13:"begrtexteshow";}i:34;a:2:{s:5:"group";s: 17:"kundenverwaltung1";s:4:"code";s:13:"preisbeisp iel";}i:35;a:2:

    and in this list there is still my borken form

    other parts of that file isnt readable.
    in other files in that zip the name of the broken-app also appears.

    does anyone know if i can in any way import all the good apps without this broken one?

    can anyone help?

    any idea??

    thanks for reading

    ((

    i cant stand this. its an so important project to me. i feel so... argh



    ----

    update next day:
    problem not solved. but i think there is no solution. i started to re-build the project, using the 2week old backup-zip. can close here.

    hot tipp:
    dont click anything as long as SC is still loading / saving what you did with the last click
    Last edited by nina_sorensen; 11-07-2013, 04:25 AM.

  • #2
    Once the SQLite DB is broken you are in big trouble although sometimes you can fix things. In this case I guess that if you had deleted your failing application you could have restored the rest. Not sure, but it would be worth a try I guess. To each and every person I recommend to use a backup tool like Conan (or any other) to make a *full* backup of you SC instance, not only backing up your projecs from the menu. If you let the backup process to run on each day you will always have an easy recovery when needed (only if you own the server that is). It realy is life saving, even on hd crashes.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment

    Working...
    X