No announcement yet.

Problem with LOGIN App

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with LOGIN App

    I have a SC generated SECURITY. I have had to modify a user database slightly to match my needs, so I added few columns and replaced one. Not sure where I messed up, but now when I try to Login as user I get message: USER NOT ACTIVE (or something like that). I checked the table and the column for activations says "YES" so I'm really not sure why this message is coming from ?
    This happens to every user.
    I was hoping I'm doing something wrong, but I did some further testing and discovered that this same problem happens with any existing database. Another words the Login only works when all Apps are generated by SC. When I tried to connect to another existing database I have gotten the same error.

    There are some SC macros involved but those are not documented (which drives me nuts!)

    The other macros used - when I looked in HELP it says nothing about how they how they work.

    Last edited by aka; 05-06-2014, 10:49 PM.
    Arthur Klisiewicz

  • #2
    The system also checks security in groups using referential integrety if I remember well, so I guess that there is something wrong there. The errormessage is some generic message as under normal circumstances this is the case when presenting the message. Set the debug options to true to see what statements are generated towards the database. I use that a lot to find my errors.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development /