Announcement

Collapse
No announcement yet.

V6 und wieder die leidigen Umlautprobleme

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • V6 und wieder die leidigen Umlautprobleme

    Hallo,
    SC 5 hate ja schon immer Probleme mit Umlauten.
    Nach der Konvertierung von Projekten nach SC6 ist es noch schlimmer .. leider ..
    In MYSQL-Tabellen habe ich halt Feldbezeichnungen mit Umlauten, z.B. Schüler_Geburtsdatum.
    Ist halt historisch so gewachsen.

    Nach der Übernahme wird in SC daraus Schler_Geburtsdatum, also das ü wird verschluckt.
    Das ist tödlich, weil ich dann das gesamte Projekt mit fast 300 Objekten komplett durchtesten müsste.

    Der Vorschlag des Supportes alles auf utf8 einzustellen hat nichts gebracht.
    latin1 löst das Problem ebenfalls nicht. Habe also die entsprechenden Zeichensätze in der SC Connection und in der Table-Definition von MYSQL eingetragen.

    Hat noch jemand eine Idee, was man probieren könnte.. ??

    LG
    Uwe Pfeiffer

  • #2
    Re: V6 und wieder die leidigen Umlautprobleme

    Hallo Uwe,
    das mit den Umlauten ist kein SC-Problem (zumindest nicht nur), es ist nun mal das leidige "Zeichensatzkodierungsproplem" und das is eine Wissenschaft für sich. Das wichtigste an der Sache is t die Datenbank und die muß nach utf8 convertiert werden.

    Eine Kurzanleitung findest Du hier: http://docs.moodle.org/22/en/Convert...tabase_to_UTF8

    Zusätzliche Komponenten die das Ganze zu einem "Katz und Maus Spiel werden lassen": Betriebssysstem Server, Betriebssystem Client, Browsereinstellungen und natürlich Scriptcase.

    Auch wenn alles scheinbar korrekt eingestellt ist kann es immer noch vorkommen daß an dem Einen oder Anderen Computer Sonderzeichen nicht korrekt dargestellt werden.

    Viel Spaß
    Stefan

    Comment


    • #3
      Re: V6 und wieder die leidigen Umlautprobleme

      Hallo Stefan,

      danke für deine Antwort.
      Das Problem bestand in einer fehlerhaften nm_netmake.db (sqllite), die von V5 auf V6 konvertiert wurde.
      V6 hat dann nur noch rumgezickt. Nach der Reparatur von V5 und danach Migration nach V6 lief es.

      Viele Grüße
      Uwe

      Comment


      • #4
        Re: V6 und wieder die leidigen Umlautprobleme

        Hab mich schon gewundert, weil bei mir funktioniert's eigentlich, selbst mit Umlauten im PK obwohl ich auf Clientseite ständig zwischen Deutsch und Englisch wechsle (OK...ein paar Ausnahmen gibts immer ;-) ).

        Stefan

        Comment

        Working...
        X