Announcement

Collapse
No announcement yet.

Problema comparando Password con la base de datos.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problema comparando Password con la base de datos.

    Hola Buenas Tardes a todos. Les quería consultar lo siguiente, en el día de la fecha me avisan los usuarios del sistema que ya no pueden entrar al mismo, que deben resetar las claves para ingresar de nuevo. Esto lo hacen con un modulo que genera la contraseña nuevamente y se las envía por correo. Voy a probar mi usuario que use hasta ayer a la noche y no puedo entrar. Verifico la tabla del Mysql donde se almacenan las claves encriptadas con md5 y esta todo correcto. Llamo al soporte del VPS donde esta alojada la aplicación y según ellos esta todo correcto, no actualizaron nada ni pisaron con ningún backup la base de datos, yo verifico que los datos son los últimos registrados, es decir no falta nada, y ademas comparo con otros backup y los password coinciden. Lo ultimo que se hizo ayer, se subieron dos aplicaciones mas, que nada tienen que ver con la tabla de usuarios. Solo puedo decir que en algun momento se quedo colgado, nada que no haya pasado antes con la famosa herramienta de publicación de scriptcase. Los usuarios han generado su clave nuevamente y han podido ingresar, sin que nosotros toquemos nada de nada , pero aquellos usuarios que todavía no han cambiado su password, siguen aun sin poder ingresar. Alguna Idea de que ocurrió. El modulo de login es el que viene por defecto en scriptcase que compara el password ingresado convirtiendo con md5 su valor y comparando contra el valor del campo que esta en la base de datos.
    Leandro Carames
    http://www.softnetbaires.com.ar

  • #2
    Trato de resumirlo en pocas palabras lo que detectamos, cuando se despliega la aplicación en el servidor de producción, automáticamente a los usuarios ya no les toma las contraseñas, deben generarlas nuevamente.
    Aclaro que no se ha modificado en absoluto el codigo que maneja el Login de la aplicacion, puntualmente usamos un formulario en blanco para probar de subirlo y ver que pasaba.
    Leandro Carames
    http://www.softnetbaires.com.ar

    Comment


    • #3
      a mi es está pasando lo mismo

      Comment


      • #4
        Anibal, pudiste ver algo de esto?
        Leandro Carames
        http://www.softnetbaires.com.ar

        Comment


        • #5
          hola lcarames,
          como dije, a mi me pasó lo mismo pero no me preocupé porq' estoy haciendo aplicaciones de prueba. Borré el usuario y lo cree de nuevo y quedó andando, pero hay algún bug aparentemente.

          Comment

          Working...
          X