Announcement

Collapse
No announcement yet.

Problema con conexion en servidor

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problema con conexion en servidor

    Estimados, paso registrar y detallar mi problema, tengo una serie de aplicaciones que corrían genial en un servidor, al hacer algunas modificaciones a algunas d ellas comenzó a darme un error de cierta linea en php, la publicar el proyecto completo nuevamente y subirlo me apareció el siguiente error " ERROR Cerrar
    Se produjo un error al acceder a la base de datos
    No database selected

    View SQL"

    Favor si alguien me puede orientar como solucionar esto
    desde ya gracias.
    Attached Files

  • #2
    Verifique la conexión si está bien y si se llama igual a la que tiene la aplicacion.

    Comment


    • #3
      hola gracias por responder, si se llama igual y la conexión la verifique en el servidor vía "localhost/_lib" me pareció raro ya que estaba funcionando y solo volví a cargar la aplicación con sus modificaciones y me pidió que re ingresara la conexión lo cual hice y quedo asi

      Comment


      • #4
        alvagar se refiere que te fijes dentro de la aplicación que te falla, si tienes definida la conexión..dentro de la aplicación, donde pone SQL y conexión
        /Giuseppe

        Professional Scriptcase Services
        Some Customers opinions

        Comment


        • #5
          a ok gracias, si esta bien igual, n ose que mas podria ser

          Comment


          • #6
            ahora me sale esto " ERROR Cerrar
            Se produjo un error al acceder a la base de datos
            Access denied for user 'decohogar'@'%' to database 'information_schema'

            View SQL"
            precido pero no lo mismo, lo pego par ver si ayuda en algo

            Comment


            • #7
              Tienes mal configurada tu conexión, esta apuntando a la bbdd de sistema de MySQL
              /Giuseppe

              Professional Scriptcase Services
              Some Customers opinions

              Comment


              • #8
                Hola ya solucione el tema, gracias, solo me dejo una gran duda, puesto que puse Driver PDO, yse arreglo, pero presento conflicto con transac y no-transacc, cosa que antes funcionaba, eso me dejo pensando, pero muchas gracias por la respuesta, sali del problema

                Comment


                • #9
                  A mi me paso algo parecido, y resulta que era la version de php, la baje de version a la 5.4.29 y funciona mucho mejor.

                  Comment


                  • #10
                    A claro eso tiene que ser ya que yo instale la ultima ahí, gracias por el dato, creo que le hare downgrade al php

                    Comment


                    • #11
                      Con 5.5 o 5.6 usando PDO creo debería funcionar. Igualmente, siempre y cuando sea posible, usar 5.4 para proyectos v8
                      /Giuseppe

                      Professional Scriptcase Services
                      Some Customers opinions

                      Comment


                      • #12
                        Si claro ese fue el tema, mira el php usado fue Version 5.6.7 , ver acá : http://deco-hogar.dyndns.org/seg_area/aplicacion/ , desde muchas gracias

                        Comment

                        Working...
                        X