No announcement yet.

ScriptCase v7.1.015 (02-18-2014 11:49)

  • Filter
  • Time
  • Show
Clear All
new posts

  • ScriptCase v7.1.015 (02-18-2014 11:49)

    New functionalities

    - Added new sample project to recruitments tracker


    - Fixed problem accessing an application that needs to inform the value of the variable.
    - Fixed problem recovering special characters in ajax events.
    - Fixed issue when using Turkish characters in ReportPDF.
    - Fixed bug in the filter conditions using TIMESTAMP in PostgreSQL.
    - Fixed problem with empty WHERE clause when searching for just the time in a TIMESTAMP field using the conditions Starting with, Contains and Does not contain.
    - Fixed problem with replicated values in the normal conditions when selecting special conditions.
    - Fixed problem in the date format in the events of PHP button.
    Best Regards,
    John L. Santos

    Bug Tracker Team
    NetMake - IT Solutions

  • #2
    So everyones problems with the upload/download filename with strange characters is not yet fixed??


    • #3
      Originally posted by rr View Post
      So everyones problems with the upload/download filename with strange characters is not yet fixed??
      Indeed! After so good documentation and sending samples and the acknowledgement that you where working on it it take rather a (very) long time. THis bug is almost two years old now....
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development /


      • #4
        I see there is a version 7.1.016 if I download it directly from the site.. What is updated in there?
        And it runs on php 5.4....


        • #5
          Aha the help file is still from the old php 5.3.something and it is basically wrong. I can not setup an sqlite connection even tho the database gets created...
          And in my php info it all nicely shows up. But connecting is a no go. So for the new version please update the help files as well....
          Anyway apparently it can not connect properly if there is no table already created in an sqlite database... When I create some table in it it works fine... Minor issue thus (tho more a minor bug to be honest).
          Last edited by rr; 02-21-2014, 09:13 AM.


          • #6
            Aparently I can upload an image as blob directly even with a + charcter in it. So i guess this a fix, it works on sqlite.
            On the other hand there is still some problem with the # character and any other character >=chr(128) in the default scriptcase.
            The + character problem is fixed... So now I can not upload files with the following charcters in it:
            # % any >=chr(128) e.g.
            I can use & +
            So nice to see that at least some work is done to fix the bugs. Just not enough yet...
            I still see that in the *_mutf8.php that the &#44 is seen asif it is a + character so that is still wrong since it is a ,
            The sajax code is still incorrect.

            It is tho partially fixed I see, if I browse for an image to be uploaded which has a % in it or a # then it does show a broken file icon but it looks like it gets uploaded anyway...
            Good work this looks better.. Now all you need to do in this 0016 version is to fix the broken icon and handle any char > 128
            Last edited by rr; 02-21-2014, 09:48 AM.


            • #7
              Error updating SC V. 7..014 to v. 7..015

              Hi, i have tried many times update my SC v7.1.014. to SC V.v7.1.015 but i got an error:

              When i anter to my SC, this message appers:

              Your ScriptCase version is outdated. You should upgrade it to get the latest implementations and fixes.

              The update process can be executed in the Settings Area (Menu Help -> Update Version) by clicking in the link ScriptCase Update.

              Then i click on sc update: this message appers:

              Search for Available Updates

              Analyzing system files...

              Searching for available updates...

              Updates found:86

              ScriptCase will now download the available updates for your system.

              When i press the button for update: i got this error message:

              The ScriptCase Update was not successfully completed.

              Critical files can not be downloaded.
              Please try again. If this problem persists contact our support.

              Click here to see the ScriptCase Update log.

              This is my log file:
              Attached Files
              Last edited by alvagar; 02-21-2014, 12:15 PM. Reason: Add a file


              • #8
                I dont see any errors in the logfile... You did do the update as user admin right? That is a must...


                • #9
                  Hello, rr Yes, i updated as user admin but SC does not updates. i have OS Windows 7. and i recently installed sc 7.1...014 with installer of SC.
                  Last edited by alvagar; 02-21-2014, 01:52 PM.


                  • #10
                    But, i have troubles, i dont think that windows needs permission on folder too.
                    What other option can i do?


                    • #11
                      I could fix it. My Antivirus Kaspersky not allow update SC, I disabled Kaspersky and worked!!


                      • #12
                        Is your scriptcase running under the administrator user itself? Check the apache scriptcase 7 service and check if it has the full rights. Check under which user the service runs and check if that user has the rights to the directories needed. The update to is rather a big update compared to the previous update. I suggest stopping the pache service and doing a full netmake directory backup first. It is virtually impossible for me to find out why it isnt working since the log file doesnt show errors. You may want to have sysinternals procmon running along, then installing. That may give you some hints. Be aware it is a program that you need to set the correct filters on.
                        Over here on windows server 2008 updates seems to work fine and on my local xp a complete new install also worked well.

                        Aha you posted just whilst I was typing.. I didnt think about the antivirus good to know that that thing should be disabled temporarily.. I could have thought of that but I didnt. Symantec is another one that can sometimes screw up installations.


                        • #13
                          When I update my scriptcase via loggin in to my to the .0016 version is it php 5.3 or php 5.4?? Since the downloadable is version 5.4...
                          I see no changelog for .0016 can someone please post it?