Announcement

Collapse
No announcement yet.

ScriptCase v8.0.003 (08-13-2014 23:10)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ScriptCase v8.0.003 (08-13-2014 23:10)

    New functionalities

    - Added option to use more than one field in the metric of option for chart applications.


    Specific correction

    - Fixed issue when using specific connection in a lookup in text type of fields.
    - Fixed problem displaying blocks on mobile devices.
    - Fixed problem when authenticating users accessing forms through mobile devices.


    Bug

    - Fixed issue when adding empty items in the tree menu.
    - Fixed issue in the menu's theme preview in the menu's settings.
    - Fixed issue displaying the sub groups buttons when the application was generated with charts.
    - Fixed issue when changing the format during the from generation.
    - Fixed issue on the chart's link when it has more than one dimension.
    - Fixed problem removing the "Number of Records" option in metric section on Chart applications.
    - Fixed issue when adding empty buttons on the menu's toolbar.
    - Fixed problem in using the macro sc_reset_global in the security module.
    - Fixed issue in the control application status after change the fields configuration.
    Best Regards,
    John L. Santos

    Bug Tracker Team
    NetMake - IT Solutions

  • #2
    Thanks for the report John,step by step
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      Thanks for the changelog, John.
      Looking through it, it seems that there are a number of critical fixes included. Given that some of us are unable to run the online update, what should we do to overcome the bugs in earlier versions?
      The GuiGuy
      ... from Down Under

      Comment


      • #4
        Originally posted by GuiGuy View Post
        Thanks for the changelog, John.
        Looking through it, it seems that there are a number of critical fixes included. Given that some of us are unable to run the online update, what should we do to overcome the bugs in earlier versions?
        Hello,

        What exactly is the problem you are having during automatic update? It's something like "Internal Server Error"?
        If yes, we have have fixed this issue internally and will be released in the next update.
        However, as this is a problem related to the environment, the Scriptcase update can not make changes in the environment, only changes to files within the folder Scriptcase.

        So to fix the problem concerning the "Internal Server Error" in Linux environments, unfortunately you will need to reinstall all Scriptcase.

        For advanced users and do not want to reinstall Scriptcase, here is a workaround to solve this problem.
        - Open the file /opt/NetMake/v8/components/apache/conf/apachesc8.conf
        - Search for FastCgiServer
        - You should find a line like FastCgiServer /opt/NetMake/v8/components/apache/cgi-bin/php.fcgi
        - Add to end of line -idle-timeout 600
        - Restart apache service
        Remembering that, for any problem you are having for automatic update, you can always do a manual update. It's quick and simple, just download the compressed package Scriptcase on our site and replace the files by their folder Scriptcase.
        Below is a link to a more detailed tutorial on how it can be done step by step

        http://support.scriptcase.net/index..../manual-update - This is a tutorial for version 7, but the same procedure can be applied to version 8.
        Last edited by John L. Santos; 08-15-2014, 09:42 AM.
        Best Regards,
        John L. Santos

        Bug Tracker Team
        NetMake - IT Solutions

        Comment


        • #5
          Great answer john... This is the way to go
          /Giuseppe

          Professional Scriptcase Services
          Some Customers opinions

          Comment


          • #6
            For advanced users and do not want to reinstall Scriptcase, here is a workaround to solve this problem.
            - Open the file /opt/NetMake/v8/components/apache/conf/apachesc8.conf
            - Search for FastCgiServer
            - You should find a line like FastCgiServer /opt/NetMake/v8/components/apache/cgi-bin/php.fcgi
            - Add to end of line -idle-timeout 600
            - Restart apache service
            Thanks. That worked.
            The GuiGuy
            ... from Down Under

            Comment

            Working...
            X