Announcement

Collapse
No announcement yet.

ScriptCase v8.0.017 (11-14-2014 17:13)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ScriptCase v8.0.017 (11-14-2014 17:13)

    New functionalities

    - Added option to group by per date or date/time in DATETIME and TIMESTAMP fields.
    - Added directory to see all tasks in TO-DO list.
    - Added tasks search in TO-DO list.
    - Added files list in "Include HelpCase" option in HelpCase.
    - Added treatment for save changes, when exiting of a modified file, in HelpCase.
    - Added themes option in events editor, templantes and libraries.
    - Added filename and file path above HelpCase editor


    Specific correction

    - Fixed problem in settings loss of group by and totalization when changing the application SQL.
    - Fixed problem in charset settings, in production environment, for MySQL PDO connection.
    (Need to update the production environment.)
    - Fixed problem in form applications when using field link type, with empty value in primary key.
    - Fixed problem when attributing a value to a datetime field and using the "Copy" button.
    - Fixed problem in mask of date field, in dynamic search with the chart module enabled.
    - Fixed problem in blocks exibition, with tabs, when are without fields.
    - Fixed problem when renaming applications that are referenced in several links.
    - Fixed problem in auto-complete of the search, of grid application.
    - Fixed problem in log module when incrementing projects.
    - Fixed problem when using variables as parameters, in sc_field_readonly macro.
    - Fixed problem in formatting of TIMESTAMP field in summary, using oracle connections.
    - Fixed problem when using search events of grid applications, inheriting for the grid application.
    - Fixed problem in auto-complete of dynamic search, when disabling the search module of grid application.
    - Fixed problem in number auto-comple fields in advanced search.


    Performance improvement

    - Improvement in HelpCase layout and performance.


    Bug

    - Fixed problem when updating a label field as filename, without being displayed in insert.
    - Fixed problem in drag n' drop of dynamic group by with a long text in the label of the field.
    - Fixed problem in icon of chart application when generating the sourcecode of application.
    - Fixed problem in resizing of the screen in Internet Explorer, with files editor of HelpCase.
    - Fixed problem when adding images inside menu's folders of HelpCase.
    - Fixed problem when linking a file to an application, in a project that hasn't applications, in HelpCase.
    - Fixed problem when using a lang along with a text in the label of dynamic group by.
    Last edited by John L. Santos; 11-14-2014, 05:41 PM.
    Best Regards,
    John L. Santos

    Bug Tracker Team
    NetMake - IT Solutions

  • #2
    Thanks John,

    thanks

    new issue appears

    from grid, click on search (advanced search) select any thing that will return value... a sudden page shows this error appear for a second then gone..

    Warning: strlen() expects parameter 1 to be string, array given in c:/xampp/project5/folder2/index.php on line 2333
    but returns search output records ok anyway

    debug and sql all are off in application tab.. this is warning i think we can manage it from php.ini but also still an issue need solution from your side


    next:
    there is really big missing for mobile
    container doesn't have back button or toolbar, if you chose to have it on mobile user can't go back after opening the container
    if you make the menu for mobile as navigation that applies, if you make the menu for mobile just "normal" it works but is really ugly showing on mobile
    any idea how to control the menu shown on mobile? either normal or even navigation menu mode?

    Comment


    • #3
      This version sure did solve some of my issues! However, did you guys change things in themes? I recompiled everything but my Saphire theme suddenly gives me a blank background where it was blue-ish and the small line if you have no menu is gone to. See samples (nothing changed, just recompiled). v1 is the latest SC release, v2 is the previous release.

      Ok, I found a little difference: {NM_CSS_FUN_CAB}
      Attached Files
      Last edited by aducom; 11-16-2014, 05:07 PM.
      Albert Drent
      aducom software netherlands
      scriptcase partner, reseller, support and (turn-key) development
      www.scriptcase.eu / www.scriptcase.nl

      Comment


      • #4
        good morning Albert,

        I agree with you, it solves the issue of the link to form when empty value is the empty parameter, however, still, a lot to do, summary doesn't work in certain cases and exit button is driving me crazy, always remove the SQL statements making message says records not found if you click exit or back!

        one thing i noticed, in some fields, i am 100% sure that i defined the center/top/middle stuff earlier but i found them gone! i did re-define them manually but i think it is the same as going for your case (alignment problem), if you have previous version installed somewhere try opening it there, see the fields css elements... perhaps you can re-apply to solve this above thing in your image


        simply, cs is doing better in general (to be optimistic) but also, sooo slow, and many things yet to come...


        regards

        Comment


        • #5
          Yes, compilation is taking longer. And there still is a lot to do for sure. But it's a lot of work so we have to be patient at some cases. In my case the background is a css issue where they modified elegant2 a bit. As I have derived my own, it did not have the changes and a simple compare did the job. Fortunately it's a template so a simple generate all was sufficient. But it takes ages now to complete. But that issue can be looked at after bugfixing which is the most important and there's a lot of work being done. But I don't expect that with so many issues that it will all be solved in one go.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #6
            Albert, juts a second please, can you check the connection to your local development environment within sc connection setup, i know it is strange but before i had it like "localhost" and it was taking ages to generate... but later (like when Mr Bean says YES!!!) changed it to 127.0.0.1 and generated in 2 seconds! like last time yesterday 42 seconds for 79 applications! and deployment the same... i guessed it was my internal hosts file or dns for localhost=127.0.0.1 but checked it it was ok not changed since windows installation... so i think it worths a try

            Comment


            • #7
              ... and try setting with 3 compilers and not 5 as default ... and use SSD and not HDD ...
              Best regards: - Reinhard -

              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

              Comment


              • #8
                Yes and use 400 volt and not 230 :-P

                I'm running SC on a virtual server (Strato) with SSD. I just compare times between the previous release and the new release. Working on a laptop / desktop is soooooo 2013 (lol)
                Albert Drent
                aducom software netherlands
                scriptcase partner, reseller, support and (turn-key) development
                www.scriptcase.eu / www.scriptcase.nl

                Comment


                • #9
                  Themes for the editors is a nice new touch - however 2 things.....

                  1) The main event and templates editor adopt the selected theme as expected - but the library editor seems to ignore any theme (uses just "default" regardless of what is selected)?

                  2) Can you modify specifics within a theme, e.g. the font used? All the themes use a proportional spaced font and I prefer a monospaced font (like Courier New, for example) when editing code - so that my code lines up nicely. So is there a way to modify a theme's properties (or copy and modify a supplied theme)?

                  Thanks

                  Comment


                  • #10
                    Originally posted by adz1111 View Post
                    [...] and I prefer a monospaced font (like Courier New, for example) when editing code - so that my code lines up nicely.
                    I'am too ...
                    Best regards: - Reinhard -

                    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

                    Comment


                    • #11
                      3rd that. In that matter I'm pretty old-fashioned....
                      Albert Drent
                      aducom software netherlands
                      scriptcase partner, reseller, support and (turn-key) development
                      www.scriptcase.eu / www.scriptcase.nl

                      Comment


                      • #12
                        I have searched for the themes and found this folder:

                        /NetMake/v8/wwwroot/scriptcase/devel/lib/third/CodeMirror/theme/

                        All the themes appear there. Will try and copy and mod one of the CSS files in there and see if that works - if it does - only concern is if updates / deployments etc wipe it away.....

                        Comment


                        • #13
                          Ok - had a play about - minimal effect.....

                          Netmake are using a third-party editor plugin called CodeMirror - had a brief look at the CM documentation online and tried a couple of things:

                          First...

                          1) Copied "blackboard.css" and called it "adz.css".
                          2) Replaced all "blackboard" therein to "adz"
                          3) Then changed first line from (this was where CodeMirror docs implies you should change "global" font settings):

                          Code:
                          .cm-s-adz.CodeMirror { background: #0C1021; color: #F8F8F8; }
                          To

                          Code:
                          .cm-s-adz.CodeMirror { font: courier; background: #0C1021; color: #F8F8F8; }
                          Log out and back into SC and then "adz" appears as a theme to choose - however that CSS change made no difference. So I then tried

                          Code:
                          .cm-s-adz.CodeMirror { font: "Courier New"; background: #0C1021; color: #F8F8F8; }
                          and then...

                          Code:
                          .cm-s-adz.CodeMirror { font-family: courier; background: #0C1021; color: #F8F8F8; }
                          Also made no difference at all. So I then tried editing CodeMirror.css (this is in /NetMake/v8/wwwroot/scriptcase/devel/lib/third/CodeMirror/lib/) - this is main template the theme files override.

                          At the top is:

                          Code:
                          /* BASICS */
                          
                          .CodeMirror {
                            /* Set height, width, borders, and global font properties here */
                            font-family: monospace;
                            height: 300px;
                          }
                          So you can see it should only be using monospaced fonts anyway! So the general mechanism is faulty it would appear. Anyway, for completeness, I tried:

                          Code:
                          /* BASICS */
                          
                          .CodeMirror {
                            /* Set height, width, borders, and global font properties here */
                            font-family: monospace;
                            font: Courier;
                            height: 300px;
                          }
                          Again - no joy. So please NM, have a look at this!

                          Thanks

                          Comment


                          • #14
                            @ Albert did you try the 127.0 0.1? i know doesn't make sense, but as i said, it was for me like YES!!! - performance increased like 500%

                            what is wrong with themes guys.. latest version 8.17 is like 16 and any other previous version nothing so special noticed for me, only that some values were were missing of the fields css elements like top-right code colors... when re added them they were ok

                            by the way, 127.0.01 connect thing was even earlier around ver 8.5 or 8.6...

                            however, one thing i noticed, when compiling apps i hear the CPU fan sound really high of the laptop intel i7 cpu 8GB ram, SSD... for as those few seconds to generate and then stops again after finish the generation... config is put to 5 compilers and obviously it consumes all pc resources for those seconds until generation is done

                            Comment


                            • #15
                              @adz, i tried that area earlier cz i was sick of the css layout and some elements didn't line up for me as required, but what i found that SC is using "complicated" folders set in development, during preview in demo then in production and when deploy changing the path of everything in "dramatically" way... add to that, each time SC updates the code you will need all the modifications again.. and hence, couldn't achieve much actually chose my 2 mostly used themes and saved as new one using their tool then each while creating new one as a copy and play around it in an advanced way.... still, many css elements are not apply as required, and hence using mostly workaround, especially the menu application css

                              Comment

                              Working...
                              X