Announcement

Collapse
No announcement yet.

ScriptCase v8.0.018 (11-17-2014 20:02)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hello John,

    look at this examples:

    A simple SELECT from a view:

    Code:
    SELECT TOP 5
        Adresse,
        sFaellig
    FROM 
        dbo.ef_vwSCOffenePosten
    WHERE sFaellig > 0
    ORDER BY sFaellig DESC
    sc_top_1.png

    Thats ok. Now i'am extend it with GROUP BY:

    Code:
    SELECT TOP 5
        Adresse,
        SUM(sFaellig) as sFaellig
    FROM 
        dbo.ef_vwSCOffenePosten
    WHERE sFaellig > 0
    GROUP BY Adresse
    ORDER BY sFaellig DESC
    After run the application:

    sc_top_2.png

    The grid fields are now undefined, but i change only the sql string ...
    Best regards: - Reinhard -

    I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

    Comment


    • #17
      Hello John,

      after other edits i mean that not TOP but SUM is the problem ... (i change the field "sFaellig" to "SUM(sFaellig) AS sFaellig" and the error appears).
      Best regards: - Reinhard -

      I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

      Comment


      • #18
        Hello,

        Please make sure your SQL is usually running on SQL Builder or any manager of SQL Server.


        sum.png
        Best Regards,
        John L. Santos

        Bug Tracker Team
        NetMake - IT Solutions

        Comment


        • #19
          John, my SQL code is always running in the SQL Server Management Studio before i write a post here ...

          In your example try this: change "SUM(freight) AS Total" to "SUM(freight) AS freight" and compile this. Presumably the error (grid fields undefined) occurs ...
          Best regards: - Reinhard -

          I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

          Comment


          • #20
            Hello,

            As you can see for yourself, I'm trying to simulate the problem by replicating the same way you're doing, and even then no problem occurs.

            I want to ask you to verify some situations:

            1. Run the command in SQL Builder and check if any error occurs.
            2. Create a new application with the SQL used and check if it works.
            3. If we can not simulate your problem, I ask you to send me your application along with the CREATE the tables involved to e-mail j.lennon@netmake.com.br

            This way I can try to simulate your problem locally.
            Just one more question, what is the connection driver are you using?

            freight.png
            I also ask that you try not to get upset, because we are all trying to help and solve the problems as quickly as possible.
            Once the problem is found, I will request that it be fixed in the next update.
            Best Regards,
            John L. Santos

            Bug Tracker Team
            NetMake - IT Solutions

            Comment


            • #21
              Originally posted by John L. Santos View Post
              As you can see for yourself, I'm trying to simulate the problem by replicating the same way you're doing, and even then no problem occurs.
              Ok, i will check this again ...

              BTW: i'am use the same conncection driver as you
              Best regards: - Reinhard -

              I use ScriptCase 8 Enterprise Edition, Version 8.(latest)

              Comment

              Working...
              X