Announcement

Collapse
No announcement yet.

ScriptCase v8.0.035 (03-19-2015 20:20)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    strange
    it works for me
    try doing digit grouping: YES and digit separator: none (blank)

    Comment


    • #17
      I tried do it from differents ways but i get same problem. This other post explaint much better what happend: http://www.scriptcase.net/forum/show...ighlight=digit

      Comment


      • #18
        Hello,

        This problem was fixed and tested internally, will be releasing in the next update.
        Best Regards,
        John L. Santos

        Bug Tracker Team
        NetMake - IT Solutions

        Comment


        • #19
          dear, are you talking about decimal point or the digit grouping? there is big difference.

          think about digits grouping like extra feature for user convenience, you can get rid of it, but decimal works the way Albert explained to you in the other post.

          again, try keep the digit grouping YES, and change it from the comma to something else, see if the comma is replaced with the new symbol you used or not... next, just make it blank or remove and hit "space" that will do

          if it doesn't, then make sure your sql data field is set to INT, TYNI INT or DECIMAL or DOUBLE

          next, make sure you have enough characters in the mysql db field like (6,2) means 4 digits and 2 decimal (total 6) then you can define how many decimal numbers you want from scriptcase itself

          sometimes, specific field gets crazy, try adding new field to your same form, see if this happens too, if doesn't, good, remove your field, sync table, add field again, and sync again, preferable to change field name if there is not much consequence... once happened to me, one field keep doing it as scriptcase wants, got me crazy as all settings were ok, i removed it and re-added it again, went all smooth

          one more thing you can try... change the type of field in scriptcase to INT, and save, generate, then again change it text, save & generate, then change it back to decimal, save and generate, see what happens... there is usual problem with sc when changing from INT to decimal, sometimes happening, you look into scriptcase field settings, what is written as html type and sql type?

          Comment


          • #20
            Originally posted by John L. Santos View Post
            Hello,

            This problem was fixed and tested internally, will be releasing in the next update.
            but john, i have 8.0.35, i don't have this problem!

            Comment


            • #21
              Thanks you Mike & John. I will wait for next realease. :-)

              Comment


              • #22
                Originally posted by MikeDE View Post
                but john, i have 8.0.35, i don't have this problem!
                This is the reason I insist un create little projects who replicates the problems to make sure its a bug
                /Giuseppe

                Professional Scriptcase Services
                Some Customers opinions

                Comment


                • #23
                  Mike - you probably do have the problem - it's a weird combo of settings that does it - in my case "regional settings" must also be on. I think it's that setting being on is what is messes up whether the digital grouping setting is "on" regardless of its set value

                  Comment


                  • #24
                    Hello,

                    This problem has been fixed and will be available in the next update.
                    Best Regards,
                    John L. Santos

                    Bug Tracker Team
                    NetMake - IT Solutions

                    Comment


                    • #25
                      Originally posted by adz1111 View Post
                      Mike - you probably do have the problem - it's a weird combo of settings that does it - in my case "regional settings" must also be on. I think it's that setting being on is what is messes up whether the digital grouping setting is "on" regardless of its set value
                      makes sense, i have regional settings always off, i don't believe in that, don't know why, even in date format, i always keep it off and set the format as it is required..

                      btw: is there anyway to keep all off for all scriptcase newly created apps? by default i mean, like general settings, always wanna know if there is default settings for fields appearance left/middle, because i do them all one by one all the time, especially for numbers, always comes "right" which i hate.. can we? just asking

                      Comment


                      • #26
                        Originally posted by MikeDE View Post
                        but john, i have 8.0.35, i don't have this problem!
                        Hi Mike!

                        but i got the problem from converted project from V7, also original apps from V6, and the first one from V5.... So the V8.0.35 its a mess converted.... I don't try your procedure however...... and if function well, I need to move all the apps? I expect to SC fix this....

                        Comment


                        • #27
                          hi adrian

                          John replied above fair enough, that they located the issue and it is fixed, he said it will be available in the next update.

                          Comment

                          Working...
                          X